summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-06-14 12:25:46 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:47 +0800
commitaaf0fc27f4f7506e2e826aab93724178a0f2b6b4 (patch)
tree3a1a9b94ff642b56d522cb2da5cd08ac2217d4ba /recipes-kernel
parentc0e4ad269c44bc7de933d5f89f519e20bbc427ac (diff)
downloadmeta-fsl-ppc-aaf0fc27f4f7506e2e826aab93724178a0f2b6b4.tar.gz
ceetm: add recipe for sdk v1.6 release
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
new file mode 100644
index 0000000..7620cdb
--- /dev/null
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5DEPENDS="virtual/kernel"
6
7inherit module
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1"
10SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16
17python () {
18 ma = d.getVar("DISTRO_FEATURES", True)
19 arch = d.getVar("OVERRIDES", True)
20
21 # the : after the arch is to skip the message on 64b
22 if not "multiarch" in ma and "e6500:" in arch:
23 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
24
25 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
26
27 if promote_kernel == "1":
28 d.setVar('KERNEL_CC_append', ' -m64')
29 d.setVar('KERNEL_LD_append', ' -melf64ppc')
30
31 error_qa = d.getVar('ERROR_QA', True)
32 if 'arch' in error_qa:
33 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
34}
35
36do_install(){
37 mkdir -p ${D}/usr/driver/ceetm
38 mkdir -p ${D}/${libdir}/tc
39 cp ${S}/bin/ceetm.ko ${D}/usr/driver/ceetm
40 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/.
41}
42
43FILES_${PN} += "/usr/driver/ceetm ${libdir}/tc"
44INHIBIT_PACKAGE_STRIP = "1"