summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-06-14 14:26:28 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:48 +0800
commit30b6558f81d30809db697484fbb5e4329f9835ea (patch)
tree3d7e49daaaeeb1484eadaf438f0923072d547c48 /recipes-kernel
parent2c1f33c0f57310142ad098ed8a7a582da74d908d (diff)
downloadmeta-fsl-ppc-30b6558f81d30809db697484fbb5e4329f9835ea.tar.gz
pkc-host: add recipe for sdk v1.6
Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/pkc-host/pkc-host_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-kernel/pkc-host/pkc-host_git.bb b/recipes-kernel/pkc-host/pkc-host_git.bb
new file mode 100644
index 0000000..9535005
--- /dev/null
+++ b/recipes-kernel/pkc-host/pkc-host_git.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "pkc host driver"
2SECTION = "pkc-host"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03"
5
6inherit module
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1"
9SRCREV = "cae512c94e2a26cc6b0d6393d307cdea2d7282c9"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
14
15python () {
16 ma = d.getVar("DISTRO_FEATURES", True)
17 arch = d.getVar("OVERRIDES", True)
18
19 # the : after the arch is to skip the message on 64b
20 if not "multiarch" in ma and ("e5500:" in arch or "e6500:" in arch):
21 raise bb.parse.SkipPackage("Building the kernel for this arch requires multiarch to be in DISTRO_FEATURES")
22
23 promote_kernel = d.getVar('BUILD_64BIT_KERNEL')
24
25 if promote_kernel == "1":
26 d.setVar('KERNEL_CC_append', ' -m64')
27 d.setVar('KERNEL_LD_append', ' -melf64ppc')
28
29 error_qa = d.getVar('ERROR_QA', True)
30 if 'arch' in error_qa:
31 d.setVar('ERROR_QA', error_qa.replace(' arch', ''))
32}
33
34do_install() {
35 install -d ${D}/lib/modules/c2x0
36 install -d ${D}/etc/crypto
37 install -d ${D}/${bindir}
38 cp ${S}/*.ko ${D}/lib/modules/c2x0
39 cp ${S}/crypto.cfg ${D}/etc/crypto
40 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto
41 cp ${S}/perf/mini_calc/mini_calc ${D}/${bindir}
42 cp ${S}/apps/cli/cli ${D}/${bindir}
43 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir}
44}
45
46
47FILES_${PN} += "${bindir}/mini_calc ${bindir}/cli ${bindir}/c29x_driver_perf_profile.sh /etc/crypto/crypto.cfg /etc/crypto/pkc-firmware.bin"