summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-11-28 11:33:41 -0600
committerMatthew McClintock <msm@freescale.com>2011-11-28 11:33:41 -0600
commit88f3d2ee358df79fc45cc74414baa3cbd457d745 (patch)
tree28be329b2c76ff5e926361c1d4d107c406851a14 /recipes-kernel
parent4c8ae9e46e1bc2442c1bbf3f60a19bb268881dc2 (diff)
downloadmeta-fsl-ppc-88f3d2ee358df79fc45cc74414baa3cbd457d745.tar.gz
Remove -mcpu= from CC as it's affecting code size
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index c1d0c69..9cc761d 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -5,7 +5,7 @@ PROVIDES = "virtual/bootloader"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
7 7
8PR = "r6" 8PR = "r7"
9INHIBIT_DEFAULT_DEPS = "1" 9INHIBIT_DEFAULT_DEPS = "1"
10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc" 10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc"
11 11
@@ -15,8 +15,8 @@ SRCREV = "348d8fceba39e5622d315ffda7d72ff6bbcf05ec"
15SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git \ 15SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git \
16 " 16 "
17 17
18EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}"' 18EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
19EXTRA_OEMAKE_e5500-64b = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} -m32" LD="${LD} -melf32ppc"' 19EXTRA_OEMAKE_e5500-64b = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} -m32" LD="${LD} -melf32ppc"'
20 20
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
22 22