summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/files
diff options
context:
space:
mode:
authorYashpal Dutta <yashpal.dutta@freescale.com>2012-11-26 15:54:34 +0800
committerMatthew McClintock <msm@freescale.com>2013-01-30 16:57:25 -0600
commite8ebd74aff666087694bef96cbb68afcb2bace59 (patch)
treee89e689224fd05b49837d4f4432b54d76e2ae821 /recipes-kernel/cryptodev/files
parentbc039f3dfd5d7299c098a2acf00de46b34c2831f (diff)
downloadmeta-fsl-ppc-e8ebd74aff666087694bef96cbb68afcb2bace59.tar.gz
cryptodev kernel module recipe
This is a /dev/crypto device driver, equivalent to those in OpenBSD or FreeBSD. The main idea is to access of existing ciphers in kernel space from userspace, thus enabling re-use of a hardware implementation of a cipher. Signed-off-by: Yashpal Dutta <yashpal.dutta@freescale.com> Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Diffstat (limited to 'recipes-kernel/cryptodev/files')
-rw-r--r--recipes-kernel/cryptodev/files/makefile_fixup.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/files/makefile_fixup.patch b/recipes-kernel/cryptodev/files/makefile_fixup.patch
new file mode 100644
index 0000000..323aacd
--- /dev/null
+++ b/recipes-kernel/cryptodev/files/makefile_fixup.patch
@@ -0,0 +1,26 @@
1diff --git a/Makefile b/Makefile
2index 2be8825..b36d68c 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -1,6 +1,7 @@
6 KBUILD_CFLAGS += -I$(src)
7 KERNEL_DIR = /lib/modules/$(shell uname -r)/build
8 VERSION = 1.5
9+PREFIX =
10
11 cryptodev-objs = ioctl.o main.o cryptlib.o authenc.o zc.o util.o
12
13@@ -12,10 +13,10 @@ build: version.h
14 version.h: Makefile
15 @echo "#define VERSION \"$(VERSION)\"" > version.h
16
17-install:
18+modules_install:
19 make -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install
20- @echo "Installing cryptodev.h in /usr/include/crypto ..."
21- @install -D crypto/cryptodev.h /usr/include/crypto/cryptodev.h
22+ @echo "Installing cryptodev.h in $(PREFIX)/usr/include/crypto ..."
23+ @install -D crypto/cryptodev.h $(PREFIX)/usr/include/crypto/cryptodev.h
24
25 clean:
26 make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean