diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 13:59:10 +0200 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2014-06-26 14:13:09 +0200 |
commit | e064c208e2c78663b0be1316117d963798839d6e (patch) | |
tree | d5d7bb0e950e5d6960d464f96f82f8132b8225c8 /recipes-graphics | |
download | meta-fsl-ppc-e064c208e2c78663b0be1316117d963798839d6e.tar.gz |
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-graphics')
5 files changed, 85 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb new file mode 100644 index 0000000..038c421 --- /dev/null +++ b/recipes-graphics/xorg-driver/xf86-video-fbdev_0.4.2.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require xorg-driver-video.inc | ||
2 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8cbd99fff773f92e844948f74ef0df8" | ||
3 | |||
4 | DESCRIPTION = "X.Org X server -- fbdev display driver" | ||
5 | PE = "1" | ||
6 | PR = "${INC_PR}.1" | ||
7 | |||
8 | DEPENDS += "virtual/xserver" | ||
9 | |||
10 | SRC_URI[md5sum] = "53a533d9e0c2da50962282526bace074" | ||
11 | SRC_URI[sha256sum] = "93b271b4b41d7e5ca108849a583b9523e96c51813d046282285355b7001f82d5" | ||
diff --git a/recipes-graphics/xorg-driver/xorg-driver-common.inc b/recipes-graphics/xorg-driver/xorg-driver-common.inc new file mode 100644 index 0000000..c0f4a15 --- /dev/null +++ b/recipes-graphics/xorg-driver/xorg-driver-common.inc | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "X driver" | ||
2 | HOMEPAGE = "http://www.x.org" | ||
3 | SECTION = "x11/drivers" | ||
4 | LICENSE = "MIT-X" | ||
5 | INC_PR = "r15" | ||
6 | |||
7 | DEPENDS = "randrproto virtual/xserver-xf86 xproto" | ||
8 | |||
9 | SRC_URI = "${XORG_MIRROR}/individual/driver/${BPN}-${PV}.tar.bz2" | ||
10 | |||
11 | S = "${WORKDIR}/${BPN}-${PV}" | ||
12 | |||
13 | FILES_${PN} += " ${libdir}/xorg/modules" | ||
14 | FILES_${PN}-dbg += "${libdir}/xorg/modules/*/.debug" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | TARGET_CPPFLAGS += "-I${STAGING_DIR_HOST}/usr/include/xorg" | ||
19 | |||
20 | # Another sucky behavor from Xorg configure scripts. | ||
21 | # They use AC_CHECK_FILE to check for DRI headers. Yuck! | ||
22 | # Of course this will blow up when cross compiling. | ||
23 | |||
24 | do_configure_prepend() { | ||
25 | incdir=${layout_includedir}/xorg | ||
26 | for f in dri.h sarea.h dristruct.h exa.h damage.h xf86Module.h; do | ||
27 | path="$incdir/$f" | ||
28 | if [ -f "${STAGING_DIR_HOST}/$path" ]; then | ||
29 | p=`echo "$path" | sed 'y%*+%pp%;s%[^_[:alnum:]]%_%g'` | ||
30 | eval "export ac_cv_file_$p=yes" | ||
31 | fi | ||
32 | done | ||
33 | } | ||
34 | |||
35 | # FIXME: We don't want to include the libtool archives (*.la) from modules | ||
36 | # directory, as they serve no useful purpose. Upstream should fix Makefile.am | ||
37 | do_install_append() { | ||
38 | find ${D}${libdir}/xorg/modules -regex ".*\.la$" | xargs rm -f -- | ||
39 | } | ||
40 | |||
diff --git a/recipes-graphics/xorg-driver/xorg-driver-video.inc b/recipes-graphics/xorg-driver/xorg-driver-video.inc new file mode 100644 index 0000000..bce8c9a --- /dev/null +++ b/recipes-graphics/xorg-driver/xorg-driver-video.inc | |||
@@ -0,0 +1,4 @@ | |||
1 | include xorg-driver-common.inc | ||
2 | |||
3 | DEPENDS = "randrproto renderproto videoproto xextproto fontsproto xproto" | ||
4 | |||
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/p1022ds/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/p1022ds/xorg.conf new file mode 100644 index 0000000..57f284e --- /dev/null +++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/p1022ds/xorg.conf | |||
@@ -0,0 +1,27 @@ | |||
1 | Section "Screen" | ||
2 | Identifier "Builtin Default fbdev Screen 0" | ||
3 | Device "Builtin Default fbdev Device 0" | ||
4 | EndSection | ||
5 | |||
6 | Section "ServerLayout" | ||
7 | Identifier "Builtin Default Layout" | ||
8 | Screen "Builtin Default fbdev Screen 0" | ||
9 | EndSection | ||
10 | |||
11 | Section "ServerFlags" | ||
12 | Option "DontZap" "0" | ||
13 | EndSection | ||
14 | |||
15 | Section "InputClass" | ||
16 | Identifier "keyboard-all" | ||
17 | Driver "evdev" | ||
18 | MatchIsKeyboard "on" | ||
19 | EndSection | ||
20 | |||
21 | |||
22 | Section "InputClass" | ||
23 | Identifier "mouse-all" | ||
24 | Driver "evdev" | ||
25 | MatchIsPointer "on" | ||
26 | EndSection | ||
27 | |||
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend new file mode 100644 index 0000000..7ae4ec2 --- /dev/null +++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_%.bbappend | |||
@@ -0,0 +1,3 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 1}" | ||