diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-07-17 17:29:03 +0800 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2015-07-20 17:19:31 +0800 |
commit | ec4711b277c209e8a43c79316f8c2a4276bd51a5 (patch) | |
tree | 301b51bebfd5cb9ff8aef58f051b7ddb6627e764 /recipes-dpaa | |
parent | 5aea3760bf645f4b91e1f56d0467f3c4864d6482 (diff) | |
download | meta-fsl-ppc-ec4711b277c209e8a43c79316f8c2a4276bd51a5.tar.gz |
dpa-offload: add recipe
The user space DPAA offloading drivers were splited from the old usdpaa.
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Acked-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa')
-rw-r--r-- | recipes-dpaa/dpa-offload/dpa-offload_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-dpaa/dpa-offload/dpa-offload_git.bb b/recipes-dpaa/dpa-offload/dpa-offload_git.bb new file mode 100644 index 0000000..73809e2 --- /dev/null +++ b/recipes-dpaa/dpa-offload/dpa-offload_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "Data-Path Acceleration Architecture Offloading User-Space Drivers" | ||
2 | LICENSE = "BSD & GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=c03ebb7a330b209986517466c74da72c" | ||
4 | |||
5 | inherit pkgconfig | ||
6 | |||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | DEPENDS = "usdpaa fmlib" | ||
10 | DEPENDS_append_b4860qds = " ipc-ust" | ||
11 | DEPENDS_append_b4420qds = " ipc-ust" | ||
12 | |||
13 | RDEPENDS_${PN} = "libgcc bash" | ||
14 | RDEPENDS_${PN}_append_b4860qds = " ipc-ust" | ||
15 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" | ||
16 | |||
17 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/dpa-offload.git;nobranch=1" | ||
18 | SRCREV = "ed6191db9439d1aaba27fc01238da770d1d8ef9e" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}"' | ||
23 | export ARCH="${TARGET_ARCH}" | ||
24 | |||
25 | PARALLEL_MAKE_pn-${PN} = "" | ||
26 | |||
27 | FMAN_VARIANT ?= "P4080" | ||
28 | FMAN_VARIANT_b4 = "FMAN_V3H" | ||
29 | FMAN_VARIANT_t1 = "FMAN_V3L" | ||
30 | FMAN_VARIANT_t2 = "FMAN_V3H" | ||
31 | FMAN_VARIANT_t4 = "FMAN_V3H" | ||
32 | FMAN_VARIANT_p1023rdb = "P1023" | ||
33 | |||
34 | do_compile_prepend () { | ||
35 | export USDPAA_CFLAGS="-I ${STAGING_INCDIR}/usdpaa" | ||
36 | export FMLIB_CFLAGS="-I ${STAGING_INCDIR}/fmd \ | ||
37 | -I ${STAGING_INCDIR}/fmd/Peripherals \ | ||
38 | -I ${STAGING_INCDIR}/fmd/integrations \ | ||
39 | -D${FMAN_VARIANT} -DNCSW_LINUX" | ||
40 | } | ||
41 | |||
42 | do_install () { | ||
43 | oe_runmake install DESTDIR=${D} | ||
44 | } | ||
45 | |||
46 | ALLOW_EMPTY_${PN} = "1" | ||
47 | |||
48 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
49 | COMPATIBLE_HOST ?= "(none)" | ||