summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-07-08 11:08:16 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2013-07-10 11:22:18 +0800
commit851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch)
tree92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-dpaa
parent55f7692b69fe273aa41f7362a9324c80515d7b52 (diff)
downloadmeta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz
change layout to follow oe-core guidelines of recipes
Follow the rules defined in: http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt recipes-bsp - Anything with links to specific hardware or hardware configuration information recipes-connectivity - Libraries and applications related to communication with other devices recipes-core - What's needed to build a basic working Linux image including commonly used dependencies recipes-devtools - Tools primarily used by the build system (but can also be used on targets) recipes-extended - Applications which whilst not essential add features compared to the alternatives in core. May be needed for full tool functionality or LSB compliance. recipes-gnome - All things related to the GTK+ application framework recipes-graphics - X and other graphically related system libraries recipes-kernel - The kernel and generic applications/libraries with strong kernel dependencies recipes-lsb4 - Recipes added for the sole purpose of supporting the Linux Standard Base (LSB) 4.x recipes-multimedia - Codecs and support utilties for audio, images and video recipes-rt - Provides package and image recipes for using and testing the PREEMPT_RT kernel recipes-qt - All things related to the Qt application framework recipes-sato - The Sato demo/reference UI/UX, its associated apps and configuration recipes-support - Recipes used by other recipes but that are not directly included in images recipes-dpaa - recipes related to fsl dpaa feature recipes-virtualization - recipes related to fsl virtualization feature Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa')
-rw-r--r--recipes-dpaa/eth-config/eth-config_git.bb19
-rw-r--r--recipes-dpaa/flib/flib_git.bb15
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb46
-rw-r--r--recipes-dpaa/fmc/fmc_git.bb53
-rw-r--r--recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch43
-rw-r--r--recipes-dpaa/fmlib/fmlib_git.bb43
-rw-r--r--recipes-dpaa/usdpaa/usdpaa_git.bb49
7 files changed, 268 insertions, 0 deletions
diff --git a/recipes-dpaa/eth-config/eth-config_git.bb b/recipes-dpaa/eth-config/eth-config_git.bb
new file mode 100644
index 0000000..ac25013
--- /dev/null
+++ b/recipes-dpaa/eth-config/eth-config_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Ethernet Configuration Files"
2SECTION = "eth-config"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=cf02dc8eb5ac4a76f3812826520dea87"
5
6PR = "r2"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/eth-config.git"
9SRCREV = "c255231fb606bff18390da3b26e1ee9fca55e4e6"
10
11S = "${WORKDIR}/git"
12
13do_install() {
14 install -d ${D}/etc/fmc/config
15 install -m 644 ${S}/*.xml ${D}/etc/fmc/config
16 install -d ${D}/etc/fmc/config/shared_mac
17 install -m 644 ${S}/shared_mac/*.xml ${D}/etc/fmc/config/shared_mac
18 install -m 644 ${S}/shared_mac/README ${D}/etc/fmc/config/shared_mac
19}
diff --git a/recipes-dpaa/flib/flib_git.bb b/recipes-dpaa/flib/flib_git.bb
new file mode 100644
index 0000000..fb3f698
--- /dev/null
+++ b/recipes-dpaa/flib/flib_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "Foundation Library"
2SECTION = "flib"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3f16fa8e677e45af3127c5c4bafc3c00"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/flib.git"
7SRCREV = "ff692ad3c286a07717c6677177825889fe17d450"
8
9S = "${WORKDIR}/git"
10
11do_install(){
12 oe_runmake install DESTDIR=${D}
13}
14
15ALLOW_EMPTY_${PN} = "1"
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
new file mode 100644
index 0000000..76d00b9
--- /dev/null
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Fman microcode binary"
2SECTION = "fm-ucode"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
5
6PR = "r1"
7
8COMPATIBLE_MACHINE = "(p1023rdb|p2041rdb|p3041ds|p4080ds|p5020ds|p5040ds|p5020ds-64b|p5040ds-64b|b4420qds|b4420qds-64b|b4860qds|b4860qds-64b|t4160qds|t4160qds-64b|t4240qds|t4240qds-64b)"
9inherit deploy
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git"
12SRCREV = "4ca0e41de225b34962e1517c2c75bbb31a381e1a"
13
14S = "${WORKDIR}/git"
15
16ALLOW_EMPTY_${PN} = "1"
17do_install () {
18 case ${MACHINE} in
19 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860qds;;
20 t4240qds|t4240qds-64b|t4160qds|t4160qds-64b) UCODE=t4240qds;;
21 p5020ds|p5020ds-64b) UCODE=p5020ds;;
22 p5040ds|p5040ds-64b) UCODE=p5040ds;;
23 *) UCODE=${MACHINE};;
24 esac
25 UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'`
26 install -d ${D}/boot
27 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/
28}
29
30do_deploy () {
31 case ${MACHINE} in
32 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860qds;;
33 t4240qds|t4240qds-64b|t4160qds|t4160qds-64b) UCODE=t4240qds;;
34 p5020ds|p5020ds-64b) UCODE=p5020ds;;
35 p5040ds|p5040ds-64b) UCODE=p5040ds;;
36 *) UCODE=${MACHINE};;
37 esac
38 UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'`
39 install -d ${DEPLOYDIR}/
40 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/
41}
42addtask deploy before do_build after do_install
43
44PACKAGES += "${PN}-image"
45FILES_${PN}-image += "/boot"
46
diff --git a/recipes-dpaa/fmc/fmc_git.bb b/recipes-dpaa/fmc/fmc_git.bb
new file mode 100644
index 0000000..20f93f6
--- /dev/null
+++ b/recipes-dpaa/fmc/fmc_git.bb
@@ -0,0 +1,53 @@
1DESCRIPTION = "Frame Manager Configuration tool"
2SECTION = "fmc"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a504ab5a8ff235e67c7301214749346c"
5
6PR = "r2"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git"
9SRCREV = "f2e1a831a96f1d04d3d5a5970d2e54c38098cf39"
10
11DEPENDS = "libxml2 fmlib tclap"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
18 FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
19 TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
20EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
21 FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
22 TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
23
24PARALLEL_MAKE = ""
25
26do_compile () {
27 if [ "b4860qds" = "${MACHINE}" ] || [ "b4420qds" = "${MACHINE}" ];then
28 EXTRA_OEMAKE_PLATFORM="b4860qds"
29 elif [ "t4240qds" = "${MACHINE}" ] || [ "t4160qds" = "${MACHINE}" ];then
30 EXTRA_OEMAKE_PLATFORM="t4240qds"
31 elif [ "p1023rds" = "${MACHINE}" ];then
32 EXTRA_OEMAKE_PLATFORM="p1023rds"
33 else
34 EXTRA_OEMAKE_PLATFORM=""
35 fi
36 oe_runmake MACHINE=${EXTRA_OEMAKE_PLATFORM} -C source
37}
38
39do_install () {
40 install -d ${D}/${bindir}
41 install -m 755 ${S}/source/fmc ${D}/${bindir}/fmc
42
43 install -d ${D}/etc/fmc/config
44 install -m 644 ${S}/etc/fmc/config/hxs_pdl_v3.xml ${D}/etc/fmc/config
45
46 install -d ${D}/${includedir}/fmc
47 install ${S}/source/fmc.h ${D}/${includedir}/fmc
48
49 install -d ${D}/${libdir}
50 install ${S}/source/libfmc.a ${D}/${libdir}
51}
52
53BBCLASSEXTEND = "native"
diff --git a/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch b/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch
new file mode 100644
index 0000000..4894ce3
--- /dev/null
+++ b/recipes-dpaa/fmlib/files/0001-fm-lib-make-the-library-install-path-configurable.patch
@@ -0,0 +1,43 @@
1From 67b539d256520f95f3c8101f4605ea6d496982df Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <b19537@freescale.com>
3Date: Thu, 18 Oct 2012 17:28:00 +0300
4Subject: [PATCH] fm-lib: make the library install path configurable
5
6currently library for both 32bit target and 64bit target
7is installed in /usr/lib folder, add a variable to make the
8install path configurable
9
10Signed-off-by: Zhenhua Luo <b19537@freescale.com>
11---
12 Makefile | 8 +++++---
13 1 file changed, 5 insertions(+), 3 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 06fe930..d59f44a 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -59,6 +59,8 @@ endif
20
21 INSTALL?=install
22
23+LIB_DEST_DIR?=$(PREFIX)/lib
24+
25 # Don't forget to increment .version before doing a new release!
26 FM_LIB_VERSION:=$(shell cat .version)
27
28@@ -118,9 +120,9 @@ archive: all .version
29
30 install-%: %.a
31 @(echo "Installing...")
32- @($(INSTALL) -d $(DESTDIR)$(PREFIX)/lib)
33- @($(INSTALL) $< $(DESTDIR)$(PREFIX)/lib)
34- @(ln -s $(DESTDIR)$(PREFIX)/lib/$< $(DESTDIR)$(PREFIX)/lib/libfm.a)
35+ @($(INSTALL) -d $(DESTDIR)$(LIB_DEST_DIR))
36+ @($(INSTALL) $< $(DESTDIR)$(LIB_DEST_DIR))
37+ @(ln -s $(DESTDIR)$(LIB_DEST_DIR)/$< $(DESTDIR)$(LIB_DEST_DIR)/libfm.a)
38 @(cp -r -p ./include $(DESTDIR)$(PREFIX))
39 @($(INSTALL) -d $(DESTDIR)$(PREFIX)/share/doc/fm-lib-$(FM_LIB_VERSION))
40 @($(INSTALL) $(FM_LIB_DOCFILES) $(DESTDIR)$(PREFIX)/share/doc/fm-lib-$(FM_LIB_VERSION))
41--
421.7.9.5
43
diff --git a/recipes-dpaa/fmlib/fmlib_git.bb b/recipes-dpaa/fmlib/fmlib_git.bb
new file mode 100644
index 0000000..7a7b8f2
--- /dev/null
+++ b/recipes-dpaa/fmlib/fmlib_git.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "Frame Manager User Space Library"
2SECTION = "fman"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3f16fa8e677e45af3127c5c4bafc3c00"
5
6PR = "r1"
7
8DEPENDS = "linux-libc-headers"
9DEPENDS_virtclass-native = ""
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git"
12SRCREV = "7d843485bdac963d98f81773c0f3cb15936e09da"
13
14S = "${WORKDIR}/git"
15
16TARGET_ARCH_FMLIB = "${DEFAULTTUNE}"
17TARGET_ARCH_FMLIB_e5500 = "ppc32e5500"
18TARGET_ARCH_FMLIB_e6500 = "ppc32e6500"
19COMPATIBLE_HOST_fslmachine = ".*"
20COMPATIBLE_HOST ?= "(none)"
21
22EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \
23 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_EXECPREFIXDIR}"
24
25do_compile () {
26 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a
27}
28
29do_compile_virtclass-native () {
30}
31
32do_install () {
33 oe_runmake install-libfm-${TARGET_ARCH_FMLIB}
34}
35
36do_install_virtclass-native () {
37 install -d ${D}/${includedir}
38 cp -rf ${S}/include/* ${D}/${includedir}
39}
40
41ALLOW_EMPTY_${PN} = "1"
42
43BBCLASSEXTEND = "native"
diff --git a/recipes-dpaa/usdpaa/usdpaa_git.bb b/recipes-dpaa/usdpaa/usdpaa_git.bb
new file mode 100644
index 0000000..48e860f
--- /dev/null
+++ b/recipes-dpaa/usdpaa/usdpaa_git.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "User-Space Data-Path Acceleration Architecture drivers"
2LICENSE = "BSD & GPLv2"
3LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
4PR = "r4"
5
6inherit pkgconfig
7
8DEPENDS = "libxml2 libedit ncurses readline flib fmc"
9RDEPENDS_${PN} = "libgcc bash"
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa.git"
12SRCREV = "97fe45d9697ef339e10a1885539b23fa7fcb113e"
13
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"'
17export ARCH="${TARGET_ARCH}"
18
19do_compile_prepend () {
20 case ${MACHINE} in
21 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) SOC=B4860;;
22 t4240qds|t4240qds-64b) SOC=T4240;;
23 p1023rdb) SOC=P1023;;
24 *) SOC=P4080;;
25 esac
26 export FMC_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmc"
27 export FMLIB_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmd \
28 -I ${STAGING_INCDIR}/fmd/Peripherals \
29 -I ${STAGING_INCDIR}/fmd/integrations \
30 -D $SOC"
31
32 export LIBXML2_CFLAGS="$(pkg-config --cflags libxml-2.0)"
33 export LIBXML2_LDFLAGS="$(pkg-config --libs --static libxml-2.0)"
34 export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
35 export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
36}
37
38do_install () {
39 oe_runmake install DESTDIR=${D}
40}
41
42PARALLEL_MAKE_pn-${PN} = ""
43FILES_${PN} += "/root/SOURCE_THIS /usr/etc/"
44
45PACKAGE_ARCH = "${MACHINE_ARCH}"
46
47COMPATIBLE_HOST_fslmachine = ".*"
48COMPATIBLE_HOST ?= "(none)"
49