summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2014-02-21 15:34:07 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-08 18:14:46 +0800
commit3ef77aa877a902d9e3f191e37c1e577607236af7 (patch)
treeabdfcc29d30b5388d707d803b3cc1d5b15cef76d /recipes-dpaa
parent14b95789762c29f9893ec8043b7e4f77a5d9db64 (diff)
downloadmeta-fsl-ppc-3ef77aa877a902d9e3f191e37c1e577607236af7.tar.gz
fmlib: update to sdk v1.6 release
add support for new added boards Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa')
-rw-r--r--recipes-dpaa/fmlib/fmlib_git.bb20
1 files changed, 13 insertions, 7 deletions
diff --git a/recipes-dpaa/fmlib/fmlib_git.bb b/recipes-dpaa/fmlib/fmlib_git.bb
index df7caf8..04ca515 100644
--- a/recipes-dpaa/fmlib/fmlib_git.bb
+++ b/recipes-dpaa/fmlib/fmlib_git.bb
@@ -9,9 +9,7 @@ DEPENDS += "virtual/kernel"
9DEPENDS_virtclass-native = "" 9DEPENDS_virtclass-native = ""
10 10
11SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;nobranch=1" 11SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;nobranch=1"
12SRCREV = "1fce11f17a102820a20cdbf80f557d74b169fc4c" 12SRCREV = "6efc100cf470f271a312860c06717928554e3492"
13SRCREV_t2080qds = "49f50a4bf4f0e34708003d7b49ce629630b68489"
14SRCREV_t2080qds-64b = "49f50a4bf4f0e34708003d7b49ce629630b68489"
15 13
16S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
17 15
@@ -25,19 +23,27 @@ EXTRA_OEMAKE = "DESTDIR=${D} PREFIX=${prefix} LIB_DEST_DIR=${libdir} \
25 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_KERNEL_DIR}" 23 CROSS_COMPILE=${TARGET_PREFIX} KERNEL_SRC=${STAGING_KERNEL_DIR}"
26 24
27do_compile () { 25do_compile () {
28 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a 26 if [ "t1040" = "${SOC_FAMILY}" -o "t1042" = "${SOC_FAMILY}" ];then
27 oe_runmake libfm-${TARGET_ARCH_FMLIB}-fmv3.a
28 else
29 oe_runmake libfm-${TARGET_ARCH_FMLIB}.a
30 fi
29} 31}
30 32
31do_compile_virtclass-native () { 33do_compile_virtclass-native () {
32} 34}
33 35
34do_install () { 36do_install () {
35 oe_runmake install-libfm-${TARGET_ARCH_FMLIB} 37 if [ "t1040" = "${SOC_FAMILY}" -o "t1042" = "${SOC_FAMILY}" ];then
38 oe_runmake install-libfm-${TARGET_ARCH_FMLIB}-fmv3
39 else
40 oe_runmake install-libfm-${TARGET_ARCH_FMLIB}
41 fi
36} 42}
37 43
38do_install_virtclass-native () { 44do_install_virtclass-native () {
39 install -d ${D}/${includedir} 45 install -d ${D}/${includedir}
40 cp -rf ${S}/include/* ${D}/${includedir} 46 cp -rf ${S}/include/* ${D}/${includedir}
41} 47}
42 48
43ALLOW_EMPTY_${PN} = "1" 49ALLOW_EMPTY_${PN} = "1"