diff options
author | Ting Liu <b28495@freescale.com> | 2013-07-08 11:08:16 +0800 |
---|---|---|
committer | Zhenhua Luo <zhenhua.luo@freescale.com> | 2013-07-10 11:22:18 +0800 |
commit | 851c7ff26de131b871bd5a64274c1a2b13d60fc3 (patch) | |
tree | 92eac21a1e1e6c3c0d27bdeaca2ff967e85c2e65 /recipes-dpaa/fm-ucode/fm-ucode_git.bb | |
parent | 55f7692b69fe273aa41f7362a9324c80515d7b52 (diff) | |
download | meta-fsl-ppc-851c7ff26de131b871bd5a64274c1a2b13d60fc3.tar.gz |
change layout to follow oe-core guidelines of recipes
Follow the rules defined in:
http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes.txt
recipes-bsp - Anything with links to specific hardware or
hardware configuration information
recipes-connectivity - Libraries and applications related to
communication with other devices
recipes-core - What's needed to build a basic working Linux
image including commonly used dependencies
recipes-devtools - Tools primarily used by the build system (but can
also be used on targets)
recipes-extended - Applications which whilst not essential add
features compared to the alternatives in
core. May be needed for full tool functionality
or LSB compliance.
recipes-gnome - All things related to the GTK+ application
framework
recipes-graphics - X and other graphically related system libraries
recipes-kernel - The kernel and generic applications/libraries
with strong kernel dependencies
recipes-lsb4 - Recipes added for the sole purpose of supporting
the Linux Standard Base (LSB) 4.x
recipes-multimedia - Codecs and support utilties for audio, images and
video
recipes-rt - Provides package and image recipes for using and
testing the PREEMPT_RT kernel
recipes-qt - All things related to the Qt application
framework
recipes-sato - The Sato demo/reference UI/UX, its associated
apps and configuration
recipes-support - Recipes used by other recipes but that are not
directly included in images
recipes-dpaa - recipes related to fsl dpaa feature
recipes-virtualization - recipes related to fsl virtualization feature
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-dpaa/fm-ucode/fm-ucode_git.bb')
-rw-r--r-- | recipes-dpaa/fm-ucode/fm-ucode_git.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb new file mode 100644 index 0000000..76d00b9 --- /dev/null +++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "Fman microcode binary" | ||
2 | SECTION = "fm-ucode" | ||
3 | LICENSE = "Freescale-EULA" | ||
4 | LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c" | ||
5 | |||
6 | PR = "r1" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(p1023rdb|p2041rdb|p3041ds|p4080ds|p5020ds|p5040ds|p5020ds-64b|p5040ds-64b|b4420qds|b4420qds-64b|b4860qds|b4860qds-64b|t4160qds|t4160qds-64b|t4240qds|t4240qds-64b)" | ||
9 | inherit deploy | ||
10 | |||
11 | SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git" | ||
12 | SRCREV = "4ca0e41de225b34962e1517c2c75bbb31a381e1a" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | ALLOW_EMPTY_${PN} = "1" | ||
17 | do_install () { | ||
18 | case ${MACHINE} in | ||
19 | b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860qds;; | ||
20 | t4240qds|t4240qds-64b|t4160qds|t4160qds-64b) UCODE=t4240qds;; | ||
21 | p5020ds|p5020ds-64b) UCODE=p5020ds;; | ||
22 | p5040ds|p5040ds-64b) UCODE=p5040ds;; | ||
23 | *) UCODE=${MACHINE};; | ||
24 | esac | ||
25 | UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'` | ||
26 | install -d ${D}/boot | ||
27 | install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/ | ||
28 | } | ||
29 | |||
30 | do_deploy () { | ||
31 | case ${MACHINE} in | ||
32 | b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860qds;; | ||
33 | t4240qds|t4240qds-64b|t4160qds|t4160qds-64b) UCODE=t4240qds;; | ||
34 | p5020ds|p5020ds-64b) UCODE=p5020ds;; | ||
35 | p5040ds|p5040ds-64b) UCODE=p5040ds;; | ||
36 | *) UCODE=${MACHINE};; | ||
37 | esac | ||
38 | UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'` | ||
39 | install -d ${DEPLOYDIR}/ | ||
40 | install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/ | ||
41 | } | ||
42 | addtask deploy before do_build after do_install | ||
43 | |||
44 | PACKAGES += "${PN}-image" | ||
45 | FILES_${PN}-image += "/boot" | ||
46 | |||