diff options
author | Matthew McClintock <msm@freescale.com> | 2012-07-25 01:12:53 +0000 |
---|---|---|
committer | Matthew McClintock <msm@freescale.com> | 2012-09-05 18:57:25 -0500 |
commit | 46f86c3fe041f83457f33d8c4c401101e6209880 (patch) | |
tree | 1a6b75cf19fea60e4ff44d2999f8fc9dc376a61e /recipes-devtools | |
parent | 3db20e4853731e7cd3343d3007854d23feeeb16c (diff) | |
download | meta-fsl-ppc-46f86c3fe041f83457f33d8c4c401101e6209880.tar.gz |
qemu: set preferred version for QEMU
The preferred version needs to specify the QEMU
version for our qemu_git recipe (overridden by
the QEMU bbappends). Without this patch we will
no pick up our qemu_git recipe.
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/qemu/qemu_1.0.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu_1.0.bb b/recipes-devtools/qemu/qemu_1.0.bb new file mode 100644 index 0000000..7a6e545 --- /dev/null +++ b/recipes-devtools/qemu/qemu_1.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | require recipes-devtools/qemu/qemu.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | ||
4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | ||
5 | |||
6 | # This means v1.0 with FSL specific patches applied | ||
7 | PV = "1.0+fsl" | ||
8 | |||
9 | DEPENDS += "dtc" | ||
10 | |||
11 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git" | ||
12 | SRCREV = "${AUTOREV}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | QEMU_TARGETS = "ppc" | ||
17 | PPC_OECONF = '${SDL} --disable-werror --disable-vnc --audio-drv-list="" --audio-card-list="" --disable-bluez --disable-curl' | ||
18 | EXTRA_OECONF_powerpc = "--target-list=ppc-softmmu ${PPC_OECONF}" | ||
19 | EXTRA_OECONF_powerpc64 = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
20 | |||
21 | do_configure_append () { | ||
22 | grep 'CONFIG_FDT=y' config-host.mak | ||
23 | } | ||
24 | |||
25 | # gets around qemu.inc trying to install powerpc_rom.bin | ||
26 | do_install_prepend() { | ||
27 | touch ${WORKDIR}/powerpc_rom.bin | ||
28 | } | ||
29 | |||
30 | do_install_append() { | ||
31 | rm ${WORKDIR}/powerpc_rom.bin | ||
32 | } | ||
33 | |||
34 | # This is only meant to be build to run on the target | ||
35 | # for the given arch types listed, otherwise don't let | ||
36 | # the package get built. COMPATIBLE_HOST would not work | ||
37 | # because it was too generic | ||
38 | COMPATIBLE_MACHINE = "a^" | ||
39 | COMPATIBLE_MACHINE_libc-glibc_fslmachine = ".*" | ||