summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-03-09 10:57:35 +0000
committerMatthew McClintock <msm@freescale.com>2012-03-13 12:41:42 -0500
commit122c5bfdad95930de96e191aafb0304fded007b2 (patch)
treeea66cb9147fed9ceacd9eacd5913b10bb64734a1 /recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch
parent4f2d99fbb0afd19376e404583700ee31428f7c2e (diff)
downloadmeta-fsl-ppc-122c5bfdad95930de96e191aafb0304fded007b2.tar.gz
integrate fsl toolchain patches
binutils: bin.e500mc_nop.patch bin.e5500.patch bin.e6500-2.patch eglibc: generate-supported.mk glibc.e500mc_subspecies_of_powerpc_is_not_supported.patch glibc.fixgcc4.6.patch glibc.fix_prof.patch glibc.fix_sqrt.patch glibc.readv_proto.patch glibc.undefined_static.patch gcc: gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch gcc.fix_longversionstring.patch gcc.rm_slow_tests.patch gcc.fix_mingw32.patch gcc.fix_cloogstatic2.patch gcc.fix_build-with-cxx.patch gcc.e6500-FSF46.patch gcc.ld_unaligned-460.patch gcc.local_unaligned_altivec.patch gcc.soft_float-460.patch gcc.case_values.patch gcc.builtin_isel.patch gcc.experimental_move.patch gcc.widen_types-46.patch gcc.extelim-v3.patch gcc.e5500_mfocr.patch gcc.opt-array-offset.patch gcc.load_on_store_bypass-462.patch gcc.fix_constvector.patch gcc.fix_MTWX51204-dwarf-vector-reg.patch gcc.fix_ira-loop-pressure.patch optional_libstdc.patch gcc.remove_CCUNSmode_reference.patch gcc.check_path_validity.patch gcc.fix_header_issue.patch gcc.fix_SSIZE_MAX_undefine_issue.patch gettext: gettext.fix_testcase.patch Signed-off-by: Zhenhua Luo <b19537@freescale.com>
Diffstat (limited to 'recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch')
-rw-r--r--recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch b/recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch
new file mode 100644
index 0000000..86ad32a
--- /dev/null
+++ b/recipes-devtools/gcc/files/gcc.fix_ira-loop-pressure.patch
@@ -0,0 +1,12 @@
1diff -Naur gcc-4.6.2/gcc/config/rs6000/rs6000.c gcc-4.6.2-loop_invariant/gcc/config/rs6000/rs6000.c
2--- gcc-4.6.2/gcc/config/rs6000/rs6000.c 2011-11-24 00:03:49.709144001 -0600
3+++ gcc-4.6.2-loop_invariant/gcc/config/rs6000/rs6000.c 2011-12-12 23:49:27.901487730 -0600
4@@ -2723,7 +2723,7 @@
5 calculation works better for RTL loop invariant motion on targets
6 with enough (>= 32) registers. It is an expensive optimization.
7 So it is on only for peak performance. */
8- if (optimize >= 3 && global_init_p)
9+ if (optimize >= 3 && global_init_p && !global_options_set.x_flag_ira_loop_pressure)
10 flag_ira_loop_pressure = 1;
11
12 /* Set the pointer size. */