summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-format/boot-format/flags.patch
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2016-01-15 17:30:44 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2016-01-15 17:30:44 +0100
commit7a99472f8509aad0799895d75e1326b76d332e21 (patch)
tree52e2e907a4bccafd45b248f1354b8093e6652253 /recipes-bsp/boot-format/boot-format/flags.patch
downloadmeta-fsl-ppc-7a99472f8509aad0799895d75e1326b76d332e21.tar.gz
initial commit for Enea Linux 5.0-ppc
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-bsp/boot-format/boot-format/flags.patch')
-rw-r--r--recipes-bsp/boot-format/boot-format/flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-bsp/boot-format/boot-format/flags.patch b/recipes-bsp/boot-format/boot-format/flags.patch
new file mode 100644
index 0000000..cddb34c
--- /dev/null
+++ b/recipes-bsp/boot-format/boot-format/flags.patch
@@ -0,0 +1,21 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -3,14 +3,14 @@
6 INSTALL=install
7 PREFIX=/usr
8
9-CFLAGS=-Wall
10+override CFLAGS+=-Wall
11
12 all: boot_format
13
14 boot_format.o: boot_format.c boot_format.h
15
16 boot_format: boot_format.o
17- $(CC) $< -o $@
18+ $(CC) $(CFLAGS) $< -o $@ $(LDFLAGS)
19
20 install: boot_format
21 $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin