diff options
author | Ting Liu <b28495@freescale.com> | 2012-02-27 10:40:53 +0000 |
---|---|---|
committer | Matthew McClintock <msm@freescale.com> | 2012-02-27 10:19:34 -0600 |
commit | e41bbda4ff0911272a49171c8b63a888aa34f55e (patch) | |
tree | 86fa7e59bf8331d55f61f3c2b631938689f2e603 /recipes-append/busybox | |
parent | 7cb414b0075bbe03e49789a6e84b7576c792b437 (diff) | |
download | meta-fsl-ppc-e41bbda4ff0911272a49171c8b63a888aa34f55e.tar.gz |
busybox: fix install error when CONFIG_INETD enabled
To avoid the following error:
| CONFIG_INETD=y
| install: cannot stat `.../busybox-1.18.5-r2/inetd': No such file or directory
| ERROR: Function 'do_install' failed
Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-append/busybox')
-rw-r--r-- | recipes-append/busybox/busybox-1.18.5/inetd | 33 | ||||
-rw-r--r-- | recipes-append/busybox/busybox-1.18.5/inetd.conf | 20 | ||||
-rw-r--r-- | recipes-append/busybox/busybox_1.18.5.bbappend | 2 |
3 files changed, 55 insertions, 0 deletions
diff --git a/recipes-append/busybox/busybox-1.18.5/inetd b/recipes-append/busybox/busybox-1.18.5/inetd new file mode 100644 index 0000000..cf50bcd --- /dev/null +++ b/recipes-append/busybox/busybox-1.18.5/inetd | |||
@@ -0,0 +1,33 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | # start/stop inetd super server. | ||
4 | |||
5 | if ! [ -x /usr/sbin/inetd ]; then | ||
6 | exit 0 | ||
7 | fi | ||
8 | |||
9 | case "$1" in | ||
10 | start) | ||
11 | echo -n "Starting internet superserver:" | ||
12 | echo -n " inetd" ; start-stop-daemon -S -x /usr/sbin/inetd > /dev/null | ||
13 | echo "." | ||
14 | ;; | ||
15 | stop) | ||
16 | echo -n "Stopping internet superserver:" | ||
17 | echo -n " inetd" ; start-stop-daemon -K -x /usr/sbin/inetd > /dev/null | ||
18 | echo "." | ||
19 | ;; | ||
20 | restart) | ||
21 | echo -n "Restarting internet superserver:" | ||
22 | echo -n " inetd " | ||
23 | killall -HUP inetd | ||
24 | echo "." | ||
25 | ;; | ||
26 | *) | ||
27 | echo "Usage: /etc/init.d/inetd {start|stop|restart}" | ||
28 | exit 1 | ||
29 | ;; | ||
30 | esac | ||
31 | |||
32 | exit 0 | ||
33 | |||
diff --git a/recipes-append/busybox/busybox-1.18.5/inetd.conf b/recipes-append/busybox/busybox-1.18.5/inetd.conf new file mode 100644 index 0000000..b02fe85 --- /dev/null +++ b/recipes-append/busybox/busybox-1.18.5/inetd.conf | |||
@@ -0,0 +1,20 @@ | |||
1 | # /etc/inetd.conf: see inetd(8) for further informations. | ||
2 | # | ||
3 | # Internet server configuration database | ||
4 | # | ||
5 | # If you want to disable an entry so it isn't touched during | ||
6 | # package updates just comment it out with a single '#' character. | ||
7 | # | ||
8 | # <service_name> <sock_type> <proto> <flags> <user> <server_path> <args> | ||
9 | # | ||
10 | #:INTERNAL: Internal services | ||
11 | #echo stream tcp nowait root internal | ||
12 | #echo dgram udp wait root internal | ||
13 | #chargen stream tcp nowait root internal | ||
14 | #chargen dgram udp wait root internal | ||
15 | #discard stream tcp nowait root internal | ||
16 | #discard dgram udp wait root internal | ||
17 | #daytime stream tcp nowait root internal | ||
18 | #daytime dgram udp wait root internal | ||
19 | #time stream tcp nowait root internal | ||
20 | #time dgram udp wait root internal | ||
diff --git a/recipes-append/busybox/busybox_1.18.5.bbappend b/recipes-append/busybox/busybox_1.18.5.bbappend index b285c16..cdf171b 100644 --- a/recipes-append/busybox/busybox_1.18.5.bbappend +++ b/recipes-append/busybox/busybox_1.18.5.bbappend | |||
@@ -2,4 +2,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/busybox-1.18.5:" | |||
2 | 2 | ||
3 | SRC_URI += "file://0001-libbb.h-do-not-use-homegrown-struct-sysinfo.patch \ | 3 | SRC_URI += "file://0001-libbb.h-do-not-use-homegrown-struct-sysinfo.patch \ |
4 | file://0002-work-around-sysinfo.h-versus-linux-.h-problems.patch \ | 4 | file://0002-work-around-sysinfo.h-versus-linux-.h-problems.patch \ |
5 | file://inetd \ | ||
6 | file://inetd.conf \ | ||
5 | " | 7 | " |