summaryrefslogtreecommitdiffstats
path: root/recipes-append/busybox/busybox_1.20.2.bbappend
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-03-12 09:20:30 +0000
committerMatthew McClintock <msm-oss@mcclintock.net>2013-03-14 20:49:33 -0500
commit8289ecd6699ebc12c35d9e42d329cf6ff77e1e33 (patch)
tree4ff3d3bf26c3c89e17aed4a01b8c3a7de4e1632f /recipes-append/busybox/busybox_1.20.2.bbappend
parent3c090cb953ea4d4a596f1dc84d0d4c61b8c54a2d (diff)
downloadmeta-fsl-ppc-8289ecd6699ebc12c35d9e42d329cf6ff77e1e33.tar.gz
busybox: remove SDK specific bits
There are three kinds of SDK specific bits: (1) deleted: busybox-1.20.2/busybox-1.19.4-ubi-user-h.patch This patch is just a workground to fix busybox 1.9 builds when enabling ubi applets (disabled by default in Yocto). The actual fix exists in kernel, but was not applied on fsl kernel git tree for SDK 1.3.x. This patch restored a compatible mtd/ubi-user.h into busybox. Now the kernel fix was already included in Yocto: http://git.yoctoproject.org/cgit/cgit.cgi/linux-yocto-3.2/commit/?id=f210735fe2f17a6225432ee3d1239bcf23a8659c http://git.yoctoproject.org/cgit/cgit.cgi/linux-yocto-3.4/commit/?id=f210735fe2f17a6225432ee3d1239bcf23a8659c http://git.yoctoproject.org/cgit/cgit.cgi/linux-yocto-3.8/commit/?id=f210735fe2f17a6225432ee3d1239bcf23a8659c commit f210735fe2f17a6225432ee3d1239bcf23a8659c headers_install: fix __packed in exported kernel headers And fsl SDK 1.4 will based on kernel 3.8 which also include this commit. So this patch can be dropped. (2) deleted: busybox-1.20.2/defconfig-fsl This defconfig is SDK specific. Remove it. (3) deleted: busybox-1.20.2/inetd{.conf} There is already submitted patches for this, but not applied: [PATCH] busybox: Add inetd related files http://patches.openembedded.org/patch/33233/ http://patches.openembedded.org/patch/33235/ The issue still exist and we will send new patches. Signed-off-by: Ting Liu <b28495@freescale.com>
Diffstat (limited to 'recipes-append/busybox/busybox_1.20.2.bbappend')
-rw-r--r--recipes-append/busybox/busybox_1.20.2.bbappend15
1 files changed, 1 insertions, 14 deletions
diff --git a/recipes-append/busybox/busybox_1.20.2.bbappend b/recipes-append/busybox/busybox_1.20.2.bbappend
index 9c52eeb..8445337 100644
--- a/recipes-append/busybox/busybox_1.20.2.bbappend
+++ b/recipes-append/busybox/busybox_1.20.2.bbappend
@@ -1,15 +1,2 @@
1PR_append_fsl = "+${DISTRO}.0" 1PRINC := "${@int(PRINC) + 1}"
2
3FILESEXTRAPATHS_prepend_fsl := "${THISDIR}/busybox-1.20.2:"
4
5SRC_URI_append_fsl += "file://defconfig-fsl \
6 file://busybox-1.19.4-ubi-user-h.patch \
7 file://inetd \
8 file://inetd.conf \
9"
10
11do_configure_prepend_fsl () {
12 cp ${WORKDIR}/defconfig-fsl ${WORKDIR}/defconfig
13}
14
15 2