summaryrefslogtreecommitdiffstats
path: root/images
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-11-21 12:37:57 -0600
committerMatthew McClintock <msm@freescale.com>2011-11-21 12:37:57 -0600
commit990a743e302eefc1b3e4cf76283420005ec232c0 (patch)
treefd1cf3b284673477eae3b16cbc002e6999a98014 /images
parent663989bedb9b6e5b4393227d0c74f2622e7db36b (diff)
downloadmeta-fsl-ppc-990a743e302eefc1b3e4cf76283420005ec232c0.tar.gz
Add u-boot to default images
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'images')
-rw-r--r--images/fsl-image-lsb-sdk.bb1
-rw-r--r--images/fsl-image-lsb.bb1
-rw-r--r--images/fsl-image-minimal.bb3
-rw-r--r--images/fsl-toolchain.bb5
4 files changed, 8 insertions, 2 deletions
diff --git a/images/fsl-image-lsb-sdk.bb b/images/fsl-image-lsb-sdk.bb
index 72b2409..04b941b 100644
--- a/images/fsl-image-lsb-sdk.bb
+++ b/images/fsl-image-lsb-sdk.bb
@@ -10,6 +10,7 @@ IMAGE_INSTALL = "\
10 flex \ 10 flex \
11 bison \ 11 bison \
12 ccache \ 12 ccache \
13 u-boot \
13 " 14 "
14 15
15inherit core-image 16inherit core-image
diff --git a/images/fsl-image-lsb.bb b/images/fsl-image-lsb.bb
index 22eb7f4..bb743b4 100644
--- a/images/fsl-image-lsb.bb
+++ b/images/fsl-image-lsb.bb
@@ -4,6 +4,7 @@ IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \ 4 ${POKY_BASE_INSTALL} \
5 task-core-basic \ 5 task-core-basic \
6 task-core-lsb \ 6 task-core-lsb \
7 u-boot \
7 " 8 "
8 9
9inherit core-image 10inherit core-image
diff --git a/images/fsl-image-minimal.bb b/images/fsl-image-minimal.bb
index 743e121..74bce63 100644
--- a/images/fsl-image-minimal.bb
+++ b/images/fsl-image-minimal.bb
@@ -1,8 +1,7 @@
1# 1#
2# Copyright (C) 2007 OpenedHand Ltd. 2# Copyright (C) 2007 OpenedHand Ltd.
3# 3#
4IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}" 4IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} u-boot"
5
6IMAGE_LINGUAS = " " 5IMAGE_LINGUAS = " "
7 6
8LICENSE = "MIT" 7LICENSE = "MIT"
diff --git a/images/fsl-toolchain.bb b/images/fsl-toolchain.bb
index 83425c7..ffc42fd 100644
--- a/images/fsl-toolchain.bb
+++ b/images/fsl-toolchain.bb
@@ -4,7 +4,12 @@ require fsl-toolchain-bare.bb
4 4
5TOOLCHAIN_OUTPUTNAME = "${SDK_NAME}-toolchain-${DISTRO_VERSION}" 5TOOLCHAIN_OUTPUTNAME = "${SDK_NAME}-toolchain-${DISTRO_VERSION}"
6TOOLCHAIN_TARGET_TASK += " \ 6TOOLCHAIN_TARGET_TASK += " \
7 gtk+-dev \
8 dtc \
7 " 9 "
10
11TOOLCHAIN_TARGET_TASK_append_e500mc = " usdpaa"
12
8TOOLCHAIN_HOST_TASK += " \ 13TOOLCHAIN_HOST_TASK += " \
9 dtc-nativesdk \ 14 dtc-nativesdk \
10 qemu-nativesdk \ 15 qemu-nativesdk \