summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-15 14:16:55 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 11:02:53 +0800
commitbe10c177a20de71209b6d5ac0db94b9531dbba3e (patch)
tree99050699c35fa6856c6665eef5fa81432b6706c6
parent1e40d6a7883b2b4488e3ffb32b43f520d3ab4951 (diff)
downloadmeta-fsl-ppc-be10c177a20de71209b6d5ac0db94b9531dbba3e.tar.gz
u-boot-qoriq: upgrade to 2016.01
The main features are: * Upgrade to 2016.01 * On ARM platforms, the U-Boot image includes the device tree * Non-secure and Secure Boot (ESBC) * Primary Protected Application (PPA) firmware integration [LS1043A] * Clock, CPLD, DUART, DDR3, DDR4, DSPI, eSDHC, GIC-400, GIC-500, I2C, OCRAM, PCIe, USB 2 & 3, SATA, UART * Networking support using eTSEC, FMAN Independent Mode or DPAA2 networking * DCU, eMMC 4.5, I2C3, LPUART, QSPI [LS1021A] * eLBC and IFC access to NOR and NAND flash * Boot from NOR, NAND flash, eSPI, SDHC * Boot from SRIO [B4860, P5020, P4080] * Voltage ID (board specific) * CodeWarrior debug patch for U-Boot Detailed commit log can be found at: http://git.freescale.com/git/cgit.cgi/ppc/sdk/u-boot.git/log/?h=sdk-v2.0.x Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch77
-rw-r--r--recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch38
-rw-r--r--recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch39
-rw-r--r--recipes-bsp/u-boot/files/gcc5.patch91
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb)6
5 files changed, 2 insertions, 249 deletions
diff --git a/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch b/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch
deleted file mode 100644
index e6b8d2e..0000000
--- a/recipes-bsp/u-boot/files/0001-u-boot-mpc85xx-u-boot-.lds-remove-_GLOBAL_OFFSET_TAB.patch
+++ /dev/null
@@ -1,77 +0,0 @@
1From 9ba002f1b1afc7af84a352f4ecab32a30d7ba353 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Mon, 9 Feb 2015 18:33:56 +0800
4Subject: [PATCH] u-boot/mpc85xx/u-boot*.lds: remove _GLOBAL_OFFSET_TABLE_
5 definition
6
7In binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbols defined by PROVIDE in
8u-boot.lds overrides the linker built-in symbols
9(https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commitdiff;h=b893397a4b1316610f49819344817715e4305de9),
10so the linker is treating _GLOBAL_OFFSET_TABLE_ as a definition into the .reloc section.
11
12To align with the change of binutils-2.25, the _GLOBAL_OFFSET_TABLE_ symbol
13should not be defined in sections, and the symbols in linker generated .got
14section should be used(https://sourceware.org/ml/binutils/2008-09/msg00122.html).
15
16Fixed the following build errors with binutils-2.25:
17| powerpc-poky-linux-gnuspe-ld.bfd: _GLOBAL_OFFSET_TABLE_ not defined in linker created .got
18
19Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
20---
21 arch/powerpc/cpu/mpc85xx/u-boot-nand.lds | 1 -
22 arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds | 1 -
23 arch/powerpc/cpu/mpc85xx/u-boot-spl.lds | 1 -
24 arch/powerpc/cpu/mpc85xx/u-boot.lds | 1 -
25 4 files changed, 4 deletions(-)
26
27diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
28index f933b21..0399f93 100644
29--- a/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
30+++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand.lds
31@@ -44,7 +44,6 @@ SECTIONS
32 _GOT2_TABLE_ = .;
33 KEEP(*(.got2))
34 KEEP(*(.got))
35- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
36 _FIXUP_TABLE_ = .;
37 KEEP(*(.fixup))
38 }
39diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
40index b83c553..f044564 100644
41--- a/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
42+++ b/arch/powerpc/cpu/mpc85xx/u-boot-nand_spl.lds
43@@ -22,7 +22,6 @@ SECTIONS
44 _GOT2_TABLE_ = .;
45 KEEP(*(.got2))
46 KEEP(*(.got))
47- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
48 _FIXUP_TABLE_ = .;
49 KEEP(*(.fixup))
50 }
51diff --git a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
52index 5ae7b3e..889a4c2 100644
53--- a/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
54+++ b/arch/powerpc/cpu/mpc85xx/u-boot-spl.lds
55@@ -29,7 +29,6 @@ SECTIONS
56 _GOT2_TABLE_ = .;
57 KEEP(*(.got2))
58 KEEP(*(.got))
59- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
60 _FIXUP_TABLE_ = .;
61 KEEP(*(.fixup))
62 }
63diff --git a/arch/powerpc/cpu/mpc85xx/u-boot.lds b/arch/powerpc/cpu/mpc85xx/u-boot.lds
64index 2cf0b25..f15eaf3 100644
65--- a/arch/powerpc/cpu/mpc85xx/u-boot.lds
66+++ b/arch/powerpc/cpu/mpc85xx/u-boot.lds
67@@ -50,7 +50,6 @@ SECTIONS
68 _GOT2_TABLE_ = .;
69 KEEP(*(.got2))
70 KEEP(*(.got))
71- PROVIDE(_GLOBAL_OFFSET_TABLE_ = . + 4);
72 _FIXUP_TABLE_ = .;
73 KEEP(*(.fixup))
74 }
75--
762.1.0
77
diff --git a/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch b/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch
deleted file mode 100644
index 1ddc667..0000000
--- a/recipes-bsp/u-boot/files/Fix-the-depend-race-issue.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1Upstream-Status: Pending
2
3From 301832414369b749918e0d5db850eed19b81c0fc Mon Sep 17 00:00:00 2001
4From: Zhenhua Luo <zhenhua.luo@freescale.com>
5Date: Tue, 24 Sep 2013 00:54:40 -0500
6Subject: [PATCH] Fix the depend race issue
7
8| make[3]: Entering directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx'
9| /srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/.depend:125: *** missing separator. Stop.
10| make[3]: Leaving directory `/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/arch/powerpc/cpu/mpc85xx'
11| make[2]: *** [/srv/home/pokybuild/yocto-autobuilder-new/yocto-slave/nightly-fsl-ppc/build/build/tmp/work/p1022ds-poky-linux-gnuspe/u-boot/git-r30/git/P1022DS_NAND/spl/arch/powerpc/cpu/mpc85xx/start.o] Error 2
12| make[2]: *** Waiting for unfinished jobs....
13
14Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
15---
16 spl/Makefile | 6 +++++-
17 1 file changed, 5 insertions(+), 1 deletion(-)
18
19diff --git a/spl/Makefile b/spl/Makefile
20index 6dbb105..3156d87 100644
21--- a/spl/Makefile
22+++ b/spl/Makefile
23@@ -185,7 +185,11 @@ $(eval $(call make_u_boot_list, $(obj)u-boot.lst, $(LIBS)))
24 $(obj)u-boot-spl.lds: $(LDSCRIPT) $(obj)u-boot.lst depend
25 $(CPP) $(CPPFLAGS) $(LDPPFLAGS) -I$(obj). -ansi -D__ASSEMBLY__ -P - < $< > $@
26
27-depend: $(obj).depend
28+# Explicitly make _depend in subdirs containing multiple targets to prevent
29+# parallel sub-makes creating .depend files simultaneously.
30+depend dep: $(obj).depend
31+ for dir in $(SUBDIRS) $(CPUDIR) $(LDSCRIPT_MAKEFILE_DIR) ; do \
32+ $(MAKE) -C $(SRCTREE)/$$dir _depend ; done
33 .PHONY: depend
34
35 # defines $(obj).depend target
36--
371.8.2.1
38
diff --git a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch b/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch
deleted file mode 100644
index cfe1c07..0000000
--- a/recipes-bsp/u-boot/files/add-fgnu89-inline-option-for-gcc5.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1Upstream-Status: Pending
2
3From 4d4fcfc41288134b48b72ac69702f68741d7631f Mon Sep 17 00:00:00 2001
4From: Ting Liu <ting.liu@freescale.com>
5Date: Tue, 28 Jul 2015 16:29:26 +0800
6Subject: [PATCH] add -fgnu89-inline option for gcc5
7
8Fix the below build issues:
9 CC drivers/crypto/fsl/sec.o
10 LD arch/powerpc/cpu/mpc8xxx/built-in.o
11arch/powerpc/cpu/mpc8xxx/fdt.o: In function `ld_le16':
12../arch/powerpc/include/asm/byteorder.h:12: multiple definition of `ld_le16'
13
14The problem is the change of the default C standard from gnu89 to gnu11
15which changes the semantics of 'inline'. The issue is described in the
16Porting guide at https://gcc.gnu.org/gcc-5/porting_to.html. Adding the
17'-fgnu89-inline' option fixes the issue.
18
19Signed-off-by: Ting Liu <ting.liu@freescale.com>
20---
21 Makefile | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/Makefile b/Makefile
25index 9995e00..00497cc 100644
26--- a/Makefile
27+++ b/Makefile
28@@ -349,7 +349,7 @@ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \
29
30 KBUILD_CPPFLAGS := -D__KERNEL__ -D__UBOOT__
31
32-KBUILD_CFLAGS := -Wall -Wstrict-prototypes \
33+KBUILD_CFLAGS := -fgnu89-inline -Wall -Wstrict-prototypes \
34 -Wno-format-security \
35 -fno-builtin -ffreestanding
36 KBUILD_AFLAGS := -D__ASSEMBLY__
37--
381.9.2
39
diff --git a/recipes-bsp/u-boot/files/gcc5.patch b/recipes-bsp/u-boot/files/gcc5.patch
deleted file mode 100644
index 12db94c..0000000
--- a/recipes-bsp/u-boot/files/gcc5.patch
+++ /dev/null
@@ -1,91 +0,0 @@
1Upstream-Status: Backport
2
3From 478b02f1a7043b673565075ea5016376f3293b23 Mon Sep 17 00:00:00 2001
4From: Hans de Goede <hdegoede@redhat.com>
5Date: Sat, 7 Feb 2015 22:52:40 +0100
6Subject: [PATCH] Add linux/compiler-gcc5.h to fix builds with gcc5
7
8Add linux/compiler-gcc5/h from the kernel sources at:
9
10commit 5631b8fba640a4ab2f8a954f63a603fa34eda96b
11Author: Steven Noonan <steven@uplinklabs.net>
12Date: Sat Oct 25 15:09:42 2014 -0700
13
14 compiler/gcc4+: Remove inaccurate comment about 'asm goto' miscompiles
15
16Signed-off-by: Hans de Goede <hdegoede@redhat.com>
17---
18 include/linux/compiler-gcc5.h | 65 +++++++++++++++++++++++++++++++++++++++++
19 1 file changed, 65 insertions(+)
20 create mode 100644 include/linux/compiler-gcc5.h
21
22Index: git/include/linux/compiler-gcc5.h
23===================================================================
24--- /dev/null
25+++ git/include/linux/compiler-gcc5.h
26@@ -0,0 +1,65 @@
27+#ifndef __LINUX_COMPILER_H
28+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
29+#endif
30+
31+#define __used __attribute__((__used__))
32+#define __must_check __attribute__((warn_unused_result))
33+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
34+
35+/* Mark functions as cold. gcc will assume any path leading to a call
36+ to them will be unlikely. This means a lot of manual unlikely()s
37+ are unnecessary now for any paths leading to the usual suspects
38+ like BUG(), printk(), panic() etc. [but let's keep them for now for
39+ older compilers]
40+
41+ Early snapshots of gcc 4.3 don't support this and we can't detect this
42+ in the preprocessor, but we can live with this because they're unreleased.
43+ Maketime probing would be overkill here.
44+
45+ gcc also has a __attribute__((__hot__)) to move hot functions into
46+ a special section, but I don't see any sense in this right now in
47+ the kernel context */
48+#define __cold __attribute__((__cold__))
49+
50+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
51+
52+#ifndef __CHECKER__
53+# define __compiletime_warning(message) __attribute__((warning(message)))
54+# define __compiletime_error(message) __attribute__((error(message)))
55+#endif /* __CHECKER__ */
56+
57+/*
58+ * Mark a position in code as unreachable. This can be used to
59+ * suppress control flow warnings after asm blocks that transfer
60+ * control elsewhere.
61+ *
62+ * Early snapshots of gcc 4.5 don't support this and we can't detect
63+ * this in the preprocessor, but we can live with this because they're
64+ * unreleased. Really, we need to have autoconf for the kernel.
65+ */
66+#define unreachable() __builtin_unreachable()
67+
68+/* Mark a function definition as prohibited from being cloned. */
69+#define __noclone __attribute__((__noclone__))
70+
71+/*
72+ * Tell the optimizer that something else uses this function or variable.
73+ */
74+#define __visible __attribute__((externally_visible))
75+
76+/*
77+ * GCC 'asm goto' miscompiles certain code sequences:
78+ *
79+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
80+ *
81+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
82+ *
83+ * (asm goto is automatically volatile - the naming reflects this.)
84+ */
85+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
86+
87+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
88+#define __HAVE_BUILTIN_BSWAP32__
89+#define __HAVE_BUILTIN_BSWAP64__
90+#define __HAVE_BUILTIN_BSWAP16__
91+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
index 4a89b30..55e5700 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
@@ -21,12 +21,10 @@ DEPENDS_append_qoriq-ppc = " boot-format-native"
21 21
22inherit deploy 22inherit deploy
23 23
24SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=sdk-v1.9.x \ 24SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=sdk-v2.0.x \
25 file://gcc5.patch \
26 file://add-fgnu89-inline-option-for-gcc5.patch \
27 file://fix-build-error-under-gcc6.patch \ 25 file://fix-build-error-under-gcc6.patch \
28" 26"
29SRCREV = "eb3d4fc5759729d7af71ac31ebf6a7e8d0e79da3" 27SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e"
30 28
31python () { 29python () {
32 if d.getVar("TCMODE", True) == "external-fsl": 30 if d.getVar("TCMODE", True) == "external-fsl":