summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-15 15:07:55 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-07-04 10:54:21 +0800
commita77d53c8ce86a320447038098ead3428babc55a2 (patch)
treeac09fb50a06ae7395ac60d5bb69ab180f59fd612
parentf4debcf9ecd69b9d6d2dbc13af0d83b1085f5fc7 (diff)
downloadmeta-fsl-ppc-a77d53c8ce86a320447038098ead3428babc55a2.tar.gz
u-boot-qoriq: sync with u-boot.inc from poky
* remove duplicate settings * sync the definition of EXTRA_OEMAKE Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
index d43a4a6..9128c65 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb
@@ -2,9 +2,7 @@ require recipes-bsp/u-boot/u-boot.inc
2inherit fsl-u-boot-localversion 2inherit fsl-u-boot-localversion
3 3
4DESCRIPTION = "U-boot provided by Freescale with focus on QorIQ boards" 4DESCRIPTION = "U-boot provided by Freescale with focus on QorIQ boards"
5HOMEPAGE = "http://u-boot.sf.net" 5PROVIDES += "u-boot"
6SECTION = "bootloaders"
7PROVIDES = "virtual/bootloader u-boot"
8LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" 6LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
9LIC_FILES_CHKSUM = " \ 7LIC_FILES_CHKSUM = " \
10 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 8 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -19,20 +17,19 @@ INHIBIT_DEFAULT_DEPS = "1"
19DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc" 17DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc"
20DEPENDS_append_qoriq-ppc = " boot-format-native" 18DEPENDS_append_qoriq-ppc = " boot-format-native"
21 19
22inherit deploy
23
24SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=sdk-v2.0.x \ 20SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=sdk-v2.0.x \
25 file://fix-build-error-under-gcc6.patch \ 21 file://fix-build-error-under-gcc6.patch \
26" 22"
27SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e" 23SRCREV = "a9b437f50e2051f8d42ec9e1a6df52de4bc00e1e"
28 24
25S = "${WORKDIR}/git"
26
29python () { 27python () {
30 if d.getVar("TCMODE", True) == "external-fsl": 28 if d.getVar("TCMODE", True) == "external-fsl":
31 return 29 return
32 30
33 ml = d.getVar("MULTILIB_VARIANTS", True) 31 ml = d.getVar("MULTILIB_VARIANTS", True)
34 arch = d.getVar("OVERRIDES", True) 32 arch = d.getVar("OVERRIDES", True)
35
36 if "e5500-64b:" in arch or "e6500-64b:" in arch: 33 if "e5500-64b:" in arch or "e6500-64b:" in arch:
37 if not "lib32" in ml: 34 if not "lib32" in ml:
38 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled") 35 raise bb.parse.SkipPackage("Building the u-boot for this arch requires multilib to be enabled")
@@ -44,16 +41,11 @@ python () {
44} 41}
45 42
46WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 43WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
47 44EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}" V=1'
48PACKAGE_ARCH = "${MACHINE_ARCH}" 45EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"'
49
50USRC ?= ""
51S = '${@base_conditional("USRC", "", "${WORKDIR}/git", "${USRC}", d)}'
52 46
53LOCALVERSION = "+fsl" 47LOCALVERSION = "+fsl"
54 48
55EXTRA_OEMAKE = 'CROSS_COMPILE=${WRAP_TARGET_PREFIX} CC="${WRAP_TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
56
57do_compile_append_qoriq-ppc () { 49do_compile_append_qoriq-ppc () {
58 unset i j 50 unset i j
59 if [ -n "${UBOOT_CONFIG}" ];then 51 if [ -n "${UBOOT_CONFIG}" ];then