summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-09-18 16:24:41 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-09-18 16:24:41 +0800
commit80bf152760cfe5bfb5c08d65e521a7d03d704c85 (patch)
tree32a4f070602adcb2583ab7e72fff485ae7585dcf
parent520c753c38ec9fb9d6b9c6c63933ed6c658b4b7c (diff)
downloadmeta-fsl-ppc-80bf152760cfe5bfb5c08d65e521a7d03d704c85.tar.gz
qemu-qoriq: fix do_install_ptest_base issue
Fix the following build error: | DEBUG: Executing shell function do_install_ptest_base | cp: cannot stat '.../qemu-qoriq/git-r1/git/tests/Makefile.include': No such file or directory | WARNING: exit code 1 from a shell command. Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index c70ed14..30daf5f 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -63,6 +63,13 @@ do_install_append() {
63 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi 63 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
64} 64}
65 65
66do_install_ptest() {
67 cp -rL ${B}/tests ${D}${PTEST_PATH}
68 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
69
70 cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests
71}
72
66FILES_${PN} += "${datadir}/qemu/" 73FILES_${PN} += "${datadir}/qemu/"
67INSANE_SKIP_${PN} += "dev-deps" 74INSANE_SKIP_${PN} += "dev-deps"
68 75