summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2016-03-22 11:04:30 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:16 +0800
commit7b112d7a853fcd7cceaf7ab483658fa49b205a9b (patch)
treecad3913552ca632c814b722ad2772351155671e1
parentd502695f9d63d499b9bf26a69147a3496783daad (diff)
downloadmeta-fsl-ppc-7b112d7a853fcd7cceaf7ab483658fa49b205a9b.tar.gz
rcw: update to 1af724b
Changelog: 1af724b update End-User License Agreement 76854c9 ls1043aqds: revise the description of SERDES1 Protocol 0x3358 970cc5d ls1043aqds: add SATA support under QSPI boot 017ed94 ls1021a/ls1043a: byte_swap: should 8 byte alignment ea90914 ls1021a: remove the unnecessary PBI 3f37603 ls1043aqds: Clear SerDes RxBoost on lane D cbf49c1 LS1043a-RDB: Add RCW files for UEFI bootloader 419bd59 ls1043ardb: SECURE_BOOT- RCW added ae3461a qe-tdm: add qe-tdm support on ls1043ardb 26042fa ls1043ardb: Add RCW for ls1043ardb board 4ae7fc3 ls1043aqds: Add RCW for ls1043aqds board * change license to Freescale-EULA * add support for fsl-lsch2 Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-bsp/rcw/rcw_git.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index ffdb547..41a0bbe 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,18 +1,18 @@
1SUMMARY = "Reset Configuration Word" 1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "Freescale-EULA"
4PR = "r8" 4LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
5 5
6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" 6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
7 7
8inherit deploy 8inherit deploy siteinfo
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v1.9.x" 10SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=sdk-v2.0.x"
11SRCREV = "521008fe6ec9897fe245e1c1241fc27dad98f24d" 11SRCREV = "1af724b64347170e9d9ba8e8f277dd30026a1a7e"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/" 15EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','').replace('-${SITEINFO_ENDIANNESS}','')} DESTDIR=${D}/boot/rcw/"
16 16
17do_install () { 17do_install () {
18 oe_runmake install 18 oe_runmake install
@@ -24,6 +24,13 @@ do_install_append_ls102xa () {
24 done 24 done
25} 25}
26 26
27do_install_append_fsl-lsch2 () {
28 for f in `find ${D}/boot/rcw/ -name "*qspiboot*"`;do
29 f_swap=`echo $f |sed -e 's/qspiboot/qspiboot_swap/'`
30 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl $f $f_swap 8
31 done
32}
33
27do_deploy () { 34do_deploy () {
28 install -d ${DEPLOYDIR}/rcw 35 install -d ${DEPLOYDIR}/rcw
29 cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/ 36 cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/