summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-05-18 12:16:16 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:18 +0800
commit64d2c36feaa158ee7b3a0da24b95bb9cdba47584 (patch)
tree9e869379c38a847d3ddb1daad0e9109799536fd8
parent261e13e34096bd28a418b2864ee0fecb71e06e37 (diff)
downloadmeta-fsl-ppc-64d2c36feaa158ee7b3a0da24b95bb9cdba47584.tar.gz
pkc-firmware: update to 21a6b5b
Changelog: ed90f15 fix dequeueing of rng descriptors b83c7e9 add FIXME note regarding response rings 39ec4f5 add support to read SEC fault registers a92d35d mark as not used the command field in dev handshake structure 06d0ca0 remove code blocks to enhance clarity f8447c5 remove not used handshake field 4955e78 describe field purpose abc3893 remove not used counters from local resources 36f23a0 rename handshake counters to match local structures cfcb505 describe the structure member bcc6f5e compact the use of if-else conditional 4b0fa3e align debug print output for easy readout 9cac843 split double assignment to clarify code b05aef4 rename functions for clarity 837d691 rename counter to be consistent with the rest of code 4d5461d fix memory allocation for interrupt flags bb46e51 group functions together for easy review f0bd7f3 introduce variable to reduce code duplication e6274e0 move #define out of the structure into a common definitions area 2257be3 rename handshake structure located on host 4129716 rename handshake structure located on the device b09a3ad describe SEC registers 0e6c428 simplify calculation of address alignment cb18b7e clarify meaning of a hard-coded register (GUTS_SVR) 45e730c group assignments and prints to simplify code review 4fca737 group together all msi and ob assignments 6eb1e08 remove useless assignment which is overwritten later 4c07318 fix calculation and print free memory 479c677 minor clean-up in code layout db7c91c add missing commas to clarify code intent 7bbdf77 remove unused "intr_ctrl_flags" field fb7b45d use offset of response ring instead of its physical address 7614c6e use offsets into ob-mem instead of host dma addresses Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-bsp/pkc-firmware/pkc-firmware_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
index 48a83cd..f5684f9 100644
--- a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
+++ b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
@@ -10,8 +10,8 @@ inherit deploy
10 10
11PACKAGE_ARCH = "${MACHINE_ARCH}" 11PACKAGE_ARCH = "${MACHINE_ARCH}"
12 12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v1.9.x" 13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v2.0.x"
14SRCREV = "32804a0d5d763b4ccc72dcd97969dc5adc14c2f9" 14SRCREV = "ed90f156389e7f0fc848f70ef015434a3f9b89ef"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17