summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-20 17:23:52 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:52 +0800
commit4f2f7fb26298be16d94d28b3533f118f83102294 (patch)
treeaf47e621d5247524ddb76dc690cada61741bbd8c
parent84cb2cc407cf85459fb463be2aabedd4f12ade77 (diff)
downloadmeta-fsl-ppc-4f2f7fb26298be16d94d28b3533f118f83102294.tar.gz
qemu: rename to qemu-qoriq
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--conf/machine/include/qoriq.inc3
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch (renamed from recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch)0
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/run-ptest (renamed from recipes-devtools/qemu/qemu/run-ptest)0
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb (renamed from recipes-devtools/qemu/qemu_fslgit.bb)14
4 files changed, 13 insertions, 4 deletions
diff --git a/conf/machine/include/qoriq.inc b/conf/machine/include/qoriq.inc
index 70cd56b..a32f1bc 100644
--- a/conf/machine/include/qoriq.inc
+++ b/conf/machine/include/qoriq.inc
@@ -7,8 +7,7 @@ PREFERRED_PROVIDER_cryptodev-linux = "cryptodev-qoriq-linux"
7PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module" 7PREFERRED_PROVIDER_cryptodev-module = "cryptodev-qoriq-module"
8PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests" 8PREFERRED_PROVIDER_cryptodev-tests = "cryptodev-qoriq-tests"
9PREFERRED_PROVIDER_openssl = "openssl-qoriq" 9PREFERRED_PROVIDER_openssl = "openssl-qoriq"
10 10PREFERRED_PROVIDER_qemu = "qemu-qoriq"
11PREFERRED_VERSION_qemu = "2.4.0+fsl"
12 11
13MACHINE_FEATURES = "keyboard pci ext2 ext3 serial" 12MACHINE_FEATURES = "keyboard pci ext2 ext3 serial"
14MACHINE_EXTRA_RRECOMMENDS += "udev-rules-qoriq kernel-modules" 13MACHINE_EXTRA_RRECOMMENDS += "udev-rules-qoriq kernel-modules"
diff --git a/recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
index a99f720..a99f720 100644
--- a/recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch
+++ b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
diff --git a/recipes-devtools/qemu/qemu/run-ptest b/recipes-devtools/qemu/qemu-qoriq/run-ptest
index f4b8e97..f4b8e97 100644
--- a/recipes-devtools/qemu/qemu/run-ptest
+++ b/recipes-devtools/qemu/qemu-qoriq/run-ptest
diff --git a/recipes-devtools/qemu/qemu_fslgit.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index 08a31a9..c70ed14 100644
--- a/recipes-devtools/qemu/qemu_fslgit.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -5,8 +5,16 @@ require recipes-devtools/qemu/qemu.inc
5LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
6 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" 6 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
7 7
8# This means QEMU v2.4.0 with FSL specific patches applied 8PROVIDES = "qemu"
9PV = "2.4.0+fsl" 9
10python() {
11 pkgs = d.getVar('PACKAGES', True).split()
12 for p in pkgs:
13 if 'qemu-qoriq' in p:
14 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
15 d.appendVar("RCONFLICTS_%s" % p, p.replace('qemu-qoriq', 'qemu'))
16 d.appendVar("RREPLACES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
17}
10 18
11# remove not supported PACKAGECONFIG by this recipe 19# remove not supported PACKAGECONFIG by this recipe
12PACKAGECONFIG[gcrypt] = "" 20PACKAGECONFIG[gcrypt] = ""
@@ -34,6 +42,8 @@ EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
34EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}" 42EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
35PACKAGECONFIG_append = " libusb" 43PACKAGECONFIG_append = " libusb"
36 44
45DISABLE_STATIC = ""
46
37do_configure_prepend() { 47do_configure_prepend() {
38 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config 48 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
39} 49}