summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 11:31:34 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 11:37:03 +0800
commit1520506e8b64e9686c415a29a688dcdb1ba721c5 (patch)
tree704f9ba3272390ca9888a906180a5c000f4a76ea
parentbe10c177a20de71209b6d5ac0db94b9531dbba3e (diff)
downloadmeta-fsl-ppc-1520506e8b64e9686c415a29a688dcdb1ba721c5.tar.gz
cryptodev: add missing patch
Fix the following build warning: | WARNING: .../meta-fsl-ppc/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.8.bb: | Unable to get checksum for cryptodev-qoriq-linux SRC_URI entry | 0001-don-t-advertise-RSA-keygen.patch: file could not be found Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-kernel/cryptodev/yocto_patches/0001-don-t-advertise-RSA-keygen.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/yocto_patches/0001-don-t-advertise-RSA-keygen.patch b/recipes-kernel/cryptodev/yocto_patches/0001-don-t-advertise-RSA-keygen.patch
new file mode 100644
index 0000000..10d6c8b
--- /dev/null
+++ b/recipes-kernel/cryptodev/yocto_patches/0001-don-t-advertise-RSA-keygen.patch
@@ -0,0 +1,33 @@
1From d30c9c64aca4a7905e1b7eb3e28e1c616191bd34 Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@freescale.com>
3Date: Tue, 9 Dec 2014 16:41:25 +0200
4Subject: [PATCH] don't advertise RSA keygen
5
6Disable RSA keygen operations when they are not available.
7
8Currently no testing can be done and this patch should be applied
9selectively on platforms that have incomplete support for RSA operations
10(for example pkc driver on C293)
11
12Change-Id: Ic8df014623410c3cf4b0b217a246efcea8f2eeef
13Signed-off-by: Cristian Stoica <cristian.stoica@freescale.com>
14---
15 ioctl.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/ioctl.c b/ioctl.c
19index 53dbf64..27dc66e 100644
20--- a/ioctl.c
21+++ b/ioctl.c
22@@ -979,7 +979,7 @@ cryptodev_ioctl(struct file *filp, unsigned int cmd, unsigned long arg_)
23 case CIOCASYMFEAT:
24 ses = 0;
25 if (crypto_has_alg("pkc(rsa)", 0, 0))
26- ses = CRF_MOD_EXP_CRT | CRF_MOD_EXP | CRF_RSA_GENERATE_KEY;
27+ ses = CRF_MOD_EXP_CRT | CRF_MOD_EXP ;
28 if (crypto_has_alg("pkc(dsa)", 0, 0))
29 ses |= CRF_DSA_SIGN | CRF_DSA_VERIFY | CRF_DSA_GENERATE_KEY;
30 if (crypto_has_alg("pkc(dh)", 0, 0))
31--
322.3.5
33