summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-05-18 14:05:48 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2016-06-23 10:58:17 +0800
commit05baca627d12fd3b7e49708d8a66cb0c6042bfea (patch)
treecf24a9a35834ef061768d24ca855a0a2c3508f03
parenta485479f17598d77e94bdfe058678da257ced898 (diff)
downloadmeta-fsl-ppc-05baca627d12fd3b7e49708d8a66cb0c6042bfea.tar.gz
pme-tools: add recipe
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch127
-rw-r--r--recipes-extended/pme-tools/pme-tools_git.bb33
2 files changed, 160 insertions, 0 deletions
diff --git a/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch b/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch
new file mode 100644
index 0000000..5839d72
--- /dev/null
+++ b/recipes-extended/pme-tools/files/0001-pme-tools-fix-build-error.patch
@@ -0,0 +1,127 @@
1From 576218f3a173dcd8b68b7c247612d1b585906742 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@nxp.com>
3Date: Wed, 13 Jan 2016 04:07:12 -0600
4Subject: [PATCH] pme-tools: fix build error
5
6Fix the following build error:
7| *.y: error: expected ';' before '}' token
8
9Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
10---
11 compilers/regularExpression/engine/pmrec.y | 6 ++--
12 compilers/statefulRule/engine/pmsrc.y | 46 ++++++++++++++--------------
13 2 files changed, 26 insertions(+), 26 deletions(-)
14
15diff --git a/compilers/regularExpression/engine/pmrec.y b/compilers/regularExpression/engine/pmrec.y
16index ececd81..a9bed4b 100644
17--- a/compilers/regularExpression/engine/pmrec.y
18+++ b/compilers/regularExpression/engine/pmrec.y
19@@ -2939,7 +2939,7 @@ input : /* empty */
20 | end_of_lines
21 | input regex
22 | input error
23- {return(pmrec_syntax_error_e)}
24+ {return(pmrec_syntax_error_e);}
25 ;
26
27 regex : start_regex branches end_regex
28@@ -3324,9 +3324,9 @@ one_character_regex : non_meta_character
29 ;
30
31 non_meta_characters : non_meta_character
32- {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++}
33+ {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++;}
34 | non_meta_characters non_meta_character
35- {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++}
36+ {_pmrec_context_p->currentPattern_p->blockAnchorNumSymbols++;}
37 ;
38
39 non_meta_character : alpha
40diff --git a/compilers/statefulRule/engine/pmsrc.y b/compilers/statefulRule/engine/pmsrc.y
41index 513e22f..0bc4d6a 100644
42--- a/compilers/statefulRule/engine/pmsrc.y
43+++ b/compilers/statefulRule/engine/pmsrc.y
44@@ -6361,45 +6361,45 @@ state_definitions : state_definition
45 ;
46
47 reserved_word : RULE_LABEL
48- {$$ = $1}
49+ {$$ = $1;}
50 | RESET_ON_LABEL
51- {$$ = $1}
52+ {$$ = $1;}
53 | RESET_STATE_LABEL
54- {$$ = $1}
55+ {$$ = $1;}
56 | EVENT_LABEL
57- {$$ = $1}
58+ {$$ = $1;}
59 | STATE_LABEL
60- {$$ = $1}
61+ {$$ = $1;}
62 | NEXT_STATE_LABEL
63- {$$ = $1}
64+ {$$ = $1;}
65 | EXIT_LABEL
66- {$$ = $1}
67+ {$$ = $1;}
68 | GPRV
69- {$$ = $1}
70+ {$$ = $1;}
71 | TEMP_GPRV
72- {$$ = $1}
73+ {$$ = $1;}
74 | GLOBAL_GPRV
75- {$$ = $1}
76+ {$$ = $1;}
77 | FLAG
78- {$$ = $1}
79+ {$$ = $1;}
80 | VOLATILE_FLAG
81- {$$ = $1}
82+ {$$ = $1;}
83 | REPORT_LABEL
84- {$$ = $1}
85+ {$$ = $1;}
86 | WRITE_LABEL
87- {$$ = $1}
88+ {$$ = $1;}
89 | WHILE
90- {$$ = $1}
91+ {$$ = $1;}
92 | BREAK
93- {$$ = $1}
94+ {$$ = $1;}
95 | IF
96- {$$ = $1}
97+ {$$ = $1;}
98 | ELSE
99- {$$ = $1}
100+ {$$ = $1;}
101 | LOGICAL_AND
102- {$$ = $1}
103+ {$$ = $1;}
104 | LOGICAL_OR
105- {$$ = $1}
106+ {$$ = $1;}
107 | END_OF_SUI
108 {$$ = $1;
109 _pmsrc_parse_warning(_pmsrc_context_p,
110@@ -6408,11 +6408,11 @@ reserved_word : RULE_LABEL
111 }
112
113 no_keywords_name : NAME
114- {$$ = $1}
115+ {$$ = $1;}
116 | DEC_NUM
117- {$$ = $1}
118+ {$$ = $1;}
119 | HEX_NUM
120- {$$ = $1}
121+ {$$ = $1;}
122 ;
123 any_name : no_keywords_name
124 | reserved_word
125--
1261.7.9.5
127
diff --git a/recipes-extended/pme-tools/pme-tools_git.bb b/recipes-extended/pme-tools/pme-tools_git.bb
new file mode 100644
index 0000000..e764153
--- /dev/null
+++ b/recipes-extended/pme-tools/pme-tools_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Pattern matcher tools"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
4
5SRC_URI = "git://git.freescale.com/ppc/sdk/pme_tools.git;branch=sdk-v2.0.x \
6 file://0001-pme-tools-fix-build-error.patch \
7"
8SRCREV = "5b6622e127ac2f3e221cc0395985ac90e2ed9533"
9
10S = "${WORKDIR}/git"
11
12PARALLEL_MAKE = ""
13EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} USE_LTIB=1 LTIB_LIB_PATH=${STAGING_LIBDIR} SYSROOT=${STAGING_DIR_TARGET} CROSS_COMPILE=${HOST_PREFIX}"
14EXTRA_CFLAGS = "-Wno-unused-but-set-parameter -Wno-enum-compare -Wno-unused-but-set-variable"
15do_compile_prepend() {
16 sed -i '/rec_yyget_leng/d' compilers/regularExpression/engine/pmrec.lex
17 sed -i '/src_yyget_leng/d' compilers/statefulRule/engine/pmsrc.lex
18 sed -i '/srcPreproc_yyget_leng/d' compilers/statefulRule/engine/pmsrc_preproc.lex
19 oe_runmake clean
20}
21
22do_install() {
23 install -m 755 -d ${D}${bindir} -d ${D}${sbindir}
24 oe_runmake INSTALL_DIR=${D}/usr install
25
26 # add runtime support files
27 install -m 755 -d ${D}/${datadir}/pme-tools/sample_rules
28 install -m 644 ltib_supp/sample* ${D}/${datadir}/pme-tools/sample_rules
29 install -m 755 -d ${D}/etc/udev/rules.d
30 install -m 644 ltib_supp/06-fsl-pme-device.rules ${D}/etc/udev/rules.d
31}
32
33COMPATIBLE_MACHINE = "(e500mc|e5500|e5500-64b|e6500|e6500-64b)"