summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2014-07-22 18:32:14 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-07-23 17:52:32 +0800
commitdd968440a80caca4e0532709f939e9e027629c7a (patch)
treea79ac8e0c36fb86494d82781cce25e8ea5666884
parentc4cdfe0f5fd8a1f09af84ad4d2629acfabb0840f (diff)
downloadmeta-fsl-ppc-dd968440a80caca4e0532709f939e9e027629c7a.tar.gz
remove obsolete patches
Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch36
-rw-r--r--recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch39
2 files changed, 0 insertions, 75 deletions
diff --git a/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch b/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch
deleted file mode 100644
index 15c397d..0000000
--- a/recipes-kernel/linux/files/libtraceevent-Remove-hard-coded-include-to-usr-local-include-in-Makefile.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1Upstream-Status: Backport
2
3From b9e8c37220c80e78289a1e87b50c09418eb59a7e Mon Sep 17 00:00:00 2001
4From: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
5Date: Fri, 08 Mar 2013 11:21:52 +0000
6Subject: libtraceevent: Remove hard coded include to /usr/local/include in Makefile
7
8having /usr/local/include hardcoded into the makefile is not necessary
9as this is automatically included by GCC. It also infects cross-compile
10builds with the host systems includes.
11
12Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk>
13Acked-by: Namhyung Kim <namhyung@kernel.org>
14Cc: Ingo Molnar <mingo@redhat.com>
15Cc: Paul Mackerras <paulus@samba.org>
16Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
17Link: http://lkml.kernel.org/r/1362741712-21308-1-git-send-email-ml@communistcode.co.uk
18Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
19---
20(limited to 'tools/lib/traceevent/Makefile')
21
22diff --git a/tools/lib/traceevent/Makefile b/tools/lib/traceevent/Makefile
23index a20e320..0b0a907 100644
24--- a/tools/lib/traceevent/Makefile
25+++ b/tools/lib/traceevent/Makefile
26@@ -122,7 +122,7 @@ export Q VERBOSE
27
28 EVENT_PARSE_VERSION = $(EP_VERSION).$(EP_PATCHLEVEL).$(EP_EXTRAVERSION)
29
30-INCLUDES = -I. -I/usr/local/include $(CONFIG_INCLUDES)
31+INCLUDES = -I. $(CONFIG_INCLUDES)
32
33 # Set compile option CFLAGS if not set elsewhere
34 CFLAGS ?= -g -Wall
35--
36cgit v0.9.2
diff --git a/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch b/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
deleted file mode 100644
index a562273..0000000
--- a/recipes-virtualization/hypervisor/files/0001-fix-sizeof-pointer-memaccess-error.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 59e68351114a65a1f315ded1ee92f4370b8547e2 Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com>
3Date: Mon, 8 Jul 2013 17:03:43 +0800
4Subject: [PATCH] fix sizeof-pointer-memaccess error
5
6build: src/livetree.c
7.../hypervisor/git-r3/git/src/devtree.c: In function 'read_intmap':
8.../hypervisor/git-r3/git/src/devtree.c:1513:25: error: argument to 'sizeof' in 'memset' call is the same expression as the destination; did you mean to dereference it? [-Werror=sizeof-pointer-memaccess]
9 memset(ent, 0, sizeof(ent));
10 ^
11cc1: all warnings being treated as errors
12build: src/ipi_doorbell.c
13make[1]: *** [bin/devtree.o] Error 1
14make[1]: *** Waiting for unfinished jobs....
15make[1]: Leaving directory `.../hypervisor/git-r3/git/output'
16make: *** [all] Error 2
17ERROR: oe_runmake failed
18
19Signed-off-by: Ting Liu <b28495@freescale.com>
20---
21 src/devtree.c | 2 +-
22 1 files changed, 1 insertions(+), 1 deletions(-)
23
24diff --git a/src/devtree.c b/src/devtree.c
25index f3710e4..3295e20 100644
26--- a/src/devtree.c
27+++ b/src/devtree.c
28@@ -1510,7 +1510,7 @@ static void read_intmap(dt_node_t *node)
29 }
30
31 if (imap + ent->parent_naddr + ent->parent_nint > imap_end) {
32- memset(ent, 0, sizeof(ent));
33+ memset(ent, 0, sizeof(intmap_entry_t));
34 break;
35 }
36
37--
381.7.5.4
39