summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-12-22 16:50:19 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-28 11:01:12 +0800
commitd61b7fd8fd6601ffa1529fedb60b16416ca2c7b6 (patch)
tree4fba048dc14b3d5d5b44b400b482f7a16f9e7f9f
parentb8f5559b76a512a05a936227b931c3d0b89964df (diff)
downloadmeta-fsl-ppc-d61b7fd8fd6601ffa1529fedb60b16416ca2c7b6.tar.gz
ipc-module: define SOC outside of do_compile
the SOC need to be availble for all tasks as it used in EXTRA_OEMAKE. otherwise, make clean will break Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-kernel/ipc/ipc-modules.inc10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-kernel/ipc/ipc-modules.inc b/recipes-kernel/ipc/ipc-modules.inc
index 79ba7ef..073e72c 100644
--- a/recipes-kernel/ipc/ipc-modules.inc
+++ b/recipes-kernel/ipc/ipc-modules.inc
@@ -9,6 +9,11 @@ inherit module qoriq_build_64bit_kernel
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12SOC ?= ""
13SOC_b4 = "B4860"
14SOC_bsc9131 = "B913x"
15SOC_bsc9132 = "B913x"
16
12do_configure[depends] += "virtual/kernel:do_shared_workdir" 17do_configure[depends] += "virtual/kernel:do_shared_workdir"
13do_configure_prepend() { 18do_configure_prepend() {
14 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile 19 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile
@@ -16,11 +21,6 @@ do_configure_prepend() {
16 21
17do_compile_prepend () { 22do_compile_prepend () {
18 cd ${S}/kernel 23 cd ${S}/kernel
19 case ${MACHINE} in
20 bsc9132qds|bsc9131rdb) SOC=B913x;;
21 b4860qds|b4420qds) SOC=B4860;;
22 esac
23} 24}
24 25
25INHIBIT_PACKAGE_STRIP = "1" 26INHIBIT_PACKAGE_STRIP = "1"
26