summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-08-18 20:47:29 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-28 11:01:08 +0800
commitc5972d99dbb6b474975337d0fdd0ea2da5d3880f (patch)
treeb2cb0df1288e6a736442fb091fcecf99c8eb86f1
parent06d86bb72271cbacbcefb477985eb86b0e4b4425 (diff)
downloadmeta-fsl-ppc-c5972d99dbb6b474975337d0fdd0ea2da5d3880f.tar.gz
pkc-firmware: update to commmit 32804a0
New commits imported: 32804a0 note on global variable definition 29a0bcb rename variable "p_cursor" and make it global 48e9ab1 remove unnecessary "l2_cursor" variable a15c204 add -Wall and -Werror to build options fa58ed6 fix typo regarding the use of "struct sec_jr_regs" 8fcd0bc enable large bursts for DECO transactions ca35ed5 refactor code for masking interrupts from SEC 3e36d4f refactor code for setting SEC pointer size 8a7f971 remove unneeded commented "print_debug()" c73303d move defines at the start of the file afcfd66 remove commented (#if 0) code 32d119a remove unnecessary type definition "kek_regs_t" 4d99599 remove unnecessary type definition "rng_regs_t" d7e65e5 refactor: added defines for better consistency 21a4853 refactor: move defines at the start of the file baa8a25 remove unnecessary type definition "sec_jr_regs_t" df0dd86 remove unnecessary type definition "sec_op_ring_t" f70c14f remove unnecessary type definition "sec_ip_ring_t" 11ed223 remove unnecessary type definition "sec_jr_t" ba47de3 remove unnecessary commented instruction b9063e4 remove unnecessary type definition "sec_engine_t" 620cf5f remove unnecessary type definition "resource_t" bef6960 remove not used function c4a078e fix incorrect handling of multiple rings 92c6b71 c2x0_boot_loader/u-boot.lds: remove _GLOBAL_OFFSET_TABLE_ definition 453eaa9 use a logical definition for MIN 570aadd rearrange code and remove leftovers after IRQ fix patch 2f31558 rename variable to better match its purpose 029cc82 remove artificial SEC dequeue and enqueue throttling b6fe293 use a bigger type for req_mem_size e22d91f fix incorrect IRQ signalling to host 692981c remove not unused #define 7e2fbd4 remove redundant c_mem_layout_t typedef 377daaa remove redundant fsl_h_mem_handshake_t typedef 52f75d0 remove redundant crypto_c_hs_mem_t typedef f126673 use smaller type for index 8c8f4ec refactoring: fix reference to the upper half of the L2 SRAM 0092a57 refactoring: remove inner code blocks 6853157 clean-up whitespace and debug-print output c3720dd refactoring hs: extract hs_complete 3677b1c refactoring hs: extract fw_init_ring_pair 78ea81b refactoring hs: extract fw init config cc416c2 minor fixes in code layout 0076df7 fix typos and clarify comments 0ab33aa remove unused variable 17607d2 use positive logic in conditional code 5d3886f Merge pull request #2 in SDK/pkc-firmware from bugfix/QSDK-2327-pkc-host-driver-does-not-insert to master c0256e0 clean-up whitespace and indentation in uboot_print.c 8f5be56 fix compiler warnings on static declarations f3bc222 use a no-op printf when PRINT_DEBUG is disabled 541a7ed make void the function c2x0_serial_init 8ecba2c enable debug prints from config.mk and move definitions to uboot_print.h 9ef2eb5 remove conditional for always-on code bd52b94 update build instructions d872219 refactoring: resetdev: extract code blocks into readable functions f5301c1 remove unused variables 0931e3b refactoring: move defines out of the function for clarity 040cb61 refactoring: secstat: extract code blocks into readable functions 77fa0e1 refactoring: pingdev: extract code blocks into readable functions 91bf581 refactoring: ringstat: extract code blocks into readable functions 7559c79 refactoring: devstat: extract code blocks into readable functions af9d455 refactoring: resetsec: extract code blocks into readable functions 17b0905 refactoring: debug: extract code blocks into readable functions 09fa9a8 remove not-used variable ae691e8 whitespace clean-up 3e6700e update build instructions Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-bsp/pkc-firmware/pkc-firmware_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
index 3cc5d44..48a83cd 100644
--- a/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
+++ b/recipes-bsp/pkc-firmware/pkc-firmware_git.bb
@@ -10,8 +10,8 @@ inherit deploy
10 10
11PACKAGE_ARCH = "${MACHINE_ARCH}" 11PACKAGE_ARCH = "${MACHINE_ARCH}"
12 12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;nobranch=1" 13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-firmware.git;branch=sdk-v1.9.x"
14SRCREV = "b891873c1eea7a7d53f9472ea601712897cb17b7" 14SRCREV = "32804a0d5d763b4ccc72dcd97969dc5adc14c2f9"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
@@ -38,4 +38,4 @@ addtask deploy after do_install
38 38
39FILES_{PN} += "/etc/crypto/pkc-firmware.bin" 39FILES_{PN} += "/etc/crypto/pkc-firmware.bin"
40COMPATIBLE_MACHINE = "(c293pcie)" 40COMPATIBLE_MACHINE = "(c293pcie)"
41 41CLEANBROKEN = "1"