summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurentiu Tudor <Laurentiu.Tudor@freescale.com>2015-10-26 14:22:42 +0200
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-28 11:01:11 +0800
commit2666439d17f28cfb42cbb9387b0e222306b1b689 (patch)
treeaba39905632169dc712f604e6b6daec28781726d
parent945a8600551cd25f787478e2e242b64757f96761 (diff)
downloadmeta-fsl-ppc-2666439d17f28cfb42cbb9387b0e222306b1b689.tar.gz
qemu: enable back libusb through PACKAGECONFIG
This fixes usb passthrough support. Signed-off-by: Laurentiu Tudor <Laurentiu.Tudor@freescale.com> Cc: Lu Wei <wei.lu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-devtools/qemu/qemu_fslgit.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-devtools/qemu/qemu_fslgit.bb b/recipes-devtools/qemu/qemu_fslgit.bb
index f977a37..b5043fb 100644
--- a/recipes-devtools/qemu/qemu_fslgit.bb
+++ b/recipes-devtools/qemu/qemu_fslgit.bb
@@ -18,13 +18,14 @@ SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a"
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20QEMU_TARGETS = "ppc" 20QEMU_TARGETS = "ppc"
21PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl --enable-libusb' 21PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl'
22EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" 22EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
23EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}" 23EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
24EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}" 24EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
25EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}" 25EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
26EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}" 26EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
27EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}" 27EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
28PACKAGECONFIG_append = " libusb"
28 29
29do_configure_prepend() { 30do_configure_prepend() {
30 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config 31 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config