summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-12-24 11:30:34 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-28 11:01:15 +0800
commit1c26752509c731e0251eadcd0bcb175c904e8822 (patch)
tree1c8100ec8888e75d49ae3025edf38d1026fe0cad
parent99690ef88cb52a18ed25e059f1328f069f415467 (diff)
downloadmeta-fsl-ppc-1c26752509c731e0251eadcd0bcb175c904e8822.tar.gz
qemu_fslgit: import ptest patches from poky
Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
-rw-r--r--recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch29
-rw-r--r--recipes-devtools/qemu/qemu/run-ptest8
-rw-r--r--recipes-devtools/qemu/qemu_fslgit.bb10
3 files changed, 46 insertions, 1 deletions
diff --git a/recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch b/recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch
new file mode 100644
index 0000000..a99f720
--- /dev/null
+++ b/recipes-devtools/qemu/qemu/add-ptest-in-makefile.patch
@@ -0,0 +1,29 @@
1Upstream-Status: Pending
2
3Add subpackage -ptest which runs all unit test cases for qemu.
4
5Signed-off-by: Kai Kang <kai.kang@windriver.com>
6---
7 tests/Makefile | 10 ++++++++++
8 1 file changed, 10 insertions(+)
9
10diff --git a/tests/Makefile b/tests/Makefile
11index 88f7105..3f40b4b 100644
12--- a/tests/Makefile
13+++ b/tests/Makefile
14@@ -405,3 +405,12 @@ all: $(QEMU_IOTESTS_HELPERS-y)
15
16 -include $(wildcard tests/*.d)
17 -include $(wildcard tests/libqos/*.d)
18+
19+buildtest-TESTS: $(check-unit-y)
20+
21+runtest-TESTS:
22+ for f in $(check-unit-y); do \
23+ nf=$$(echo $$f | sed 's/tests\//\.\//g'); \
24+ $$nf; \
25+ done
26+
27--
281.7.9.5
29
diff --git a/recipes-devtools/qemu/qemu/run-ptest b/recipes-devtools/qemu/qemu/run-ptest
new file mode 100644
index 0000000..f4b8e97
--- /dev/null
+++ b/recipes-devtools/qemu/qemu/run-ptest
@@ -0,0 +1,8 @@
1#!/bin/sh
2#
3#This script is used to run qemu test suites
4ptestdir=$(pwd)
5cd tests
6
7export SRC_PATH=$ptestdir
8make -k runtest-TESTS | sed '/: OK/ s/^/PASS: /g'
diff --git a/recipes-devtools/qemu/qemu_fslgit.bb b/recipes-devtools/qemu/qemu_fslgit.bb
index d0994b4..1433b9f 100644
--- a/recipes-devtools/qemu/qemu_fslgit.bb
+++ b/recipes-devtools/qemu/qemu_fslgit.bb
@@ -1,3 +1,5 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
1require recipes-devtools/qemu/qemu.inc 3require recipes-devtools/qemu/qemu.inc
2 4
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
@@ -6,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
6# This means QEMU v2.2.0 with FSL specific patches applied 8# This means QEMU v2.2.0 with FSL specific patches applied
7PV = "2.2.0+fsl" 9PV = "2.2.0+fsl"
8 10
9# NOTE: this recipe requires poky's qemu.inc which assumes version 2.3 11# FIXME: this recipe requires poky's qemu.inc which assumes version 2.3
10# where glx enable config option changed to --enable-opengl. For now we 12# where glx enable config option changed to --enable-opengl. For now we
11# restore it, but we should remove the following lines when upgrading 13# restore it, but we should remove the following lines when upgrading
12# to qemu 2.3: 14# to qemu 2.3:
@@ -17,6 +19,12 @@ PACKAGECONFIG[gnutls] = ""
17SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.9.x" 19SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.9.x"
18SRCREV = "8362a298c4feef33c84d7db2d111af18bd29ef86" 20SRCREV = "8362a298c4feef33c84d7db2d111af18bd29ef86"
19 21
22# add ptest patches
23SRC_URI_append = "\
24 file://add-ptest-in-makefile.patch \
25 file://run-ptest \
26"
27
20S = "${WORKDIR}/git" 28S = "${WORKDIR}/git"
21 29
22QEMU_TARGETS = "ppc" 30QEMU_TARGETS = "ppc"