summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-12-23 00:07:48 +0800
committerZhenhua Luo <zhenhua.luo@nxp.com>2015-12-23 14:22:53 +0800
commitb46c906b0eff13a2ef610b6389a88382862e2e5d (patch)
tree7809e4811f0581e9dea172b81b644b6382ea3784
parent50fc7a56eedf62059881dbb3a8d80364e9e56617 (diff)
downloadmeta-fsl-ppc-b46c906b0eff13a2ef610b6389a88382862e2e5d.tar.gz
usdpaa-apps: use in6_* macros from glibc instead of kernel
Both glibc and the kernel have in6_* macros definition. Use the one from glibc. Kernel headers will check for previous libc definitions by including include/linux/libc-compat.h. Fix the below build error: | [CC] xfrm_km.c (bin:srio_ipsec_offload) | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | from src/srio_ipsec_offload/xfrm_km.c:46: | .../usr/include/netinet/in.h:99:5: error: expected identifier before numeric constant | IPPROTO_HOPOPTS = 0, /* IPv6 Hop-by-Hop options. */ | ^ | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/netinet/ip.h:24:0, | from src/srio_ipsec_offload/xfrm_km.c:52: | .../tmp/sysroots/b4860qds-64b/usr/include/netinet/in.h:209:8: error: redefinition of 'struct in6_addr' | struct in6_addr | ^ | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | from src/srio_ipsec_offload/xfrm_km.c:46: | .../tmp/sysroots/b4860qds-64b/usr/include/linux/in6.h:32:8: note: originally defined here | struct in6_addr { | ^ Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch49
-rw-r--r--recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch b/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch
new file mode 100644
index 0000000..c6d35f0
--- /dev/null
+++ b/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch
@@ -0,0 +1,49 @@
1From 1e1e8d74db98faed57a5a62788e1226801661e0e Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@freescale.com>
3Date: Tue, 22 Dec 2015 23:37:49 +0800
4Subject: [PATCH] xfrm_km.c: use in6_* macros from glibc instead of kernel
5
6Both glibc and the kernel have in6_* macros definition. Use the one from glibc.
7Kernel headers will check for previous libc definitions by including
8include/linux/libc-compat.h.
9
10Fix the below build error:
11| [CC] xfrm_km.c (bin:srio_ipsec_offload)
12| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0,
13| from src/srio_ipsec_offload/xfrm_km.c:46:
14| .../usr/include/netinet/in.h:99:5: error: expected identifier before numeric constant
15| IPPROTO_HOPOPTS = 0, /* IPv6 Hop-by-Hop options. */
16| ^
17| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/netinet/ip.h:24:0,
18| from src/srio_ipsec_offload/xfrm_km.c:52:
19| .../tmp/sysroots/b4860qds-64b/usr/include/netinet/in.h:209:8: error: redefinition of 'struct in6_addr'
20| struct in6_addr
21| ^
22| In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0,
23| from src/srio_ipsec_offload/xfrm_km.c:46:
24| .../tmp/sysroots/b4860qds-64b/usr/include/linux/in6.h:32:8: note: originally defined here
25| struct in6_addr {
26| ^
27
28Upstream-Status: Pending
29
30Signed-off-by: Ting Liu <ting.liu@freescale.com>
31---
32 src/srio_ipsec_offload/xfrm_km.c | 1 +
33 1 file changed, 1 insertion(+)
34
35diff --git a/src/srio_ipsec_offload/xfrm_km.c b/src/srio_ipsec_offload/xfrm_km.c
36index df23fd1..d69aafa 100644
37--- a/src/srio_ipsec_offload/xfrm_km.c
38+++ b/src/srio_ipsec_offload/xfrm_km.c
39@@ -42,6 +42,7 @@
40 #include <linux/types.h>
41 #include <sys/socket.h>
42 #include <sys/ioctl.h>
43+#include <netinet/in.h>
44 #include <linux/netlink.h>
45 #include <linux/xfrm.h>
46 #include <sched.h>
47--
481.9.2
49
diff --git a/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb b/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb
index 837c45a..57b7546 100644
--- a/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb
+++ b/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb
@@ -16,6 +16,7 @@ RDEPENDS_${PN}_append_b4420qds = " ipc-ust"
16 16
17SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps;nobranch=1 \ 17SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps;nobranch=1 \
18 file://fix-the-inline-function-definition-with-gcc-5.x.patch \ 18 file://fix-the-inline-function-definition-with-gcc-5.x.patch \
19 file://xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch \
19" 20"
20SRCREV = "95744440cf214d73884c44c0dbc296e1e4b4c8f4" 21SRCREV = "95744440cf214d73884c44c0dbc296e1e4b4c8f4"
21 22