summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-04-14 17:25:18 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-04-24 10:17:12 +0800
commit4e149280e1958dbb188d95eca9d453d08ea510b3 (patch)
tree1636b06bcbe677c0a3ea28673a65ff564fe14d80
parent4c8cd553f9de56379e2b6502ceb996521e2d6a20 (diff)
downloadmeta-fsl-ppc-4e149280e1958dbb188d95eca9d453d08ea510b3.tar.gz
asf: fix configure error
fix the following error: |make: *** No rule to make target `/poky/build/tmp/work-shared/p4080ds/kernel-source/.config (From OE-Core rev: 6a1ff0e7eacef595738f2fed086986fd622ec32a) Signed-off-by: Chunrong Guo <B40290@freescale.com>
-rw-r--r--recipes-kernel/asf/asf_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
index 8070f5a..b3379c1 100644
--- a/recipes-kernel/asf/asf_git.bb
+++ b/recipes-kernel/asf/asf_git.bb
@@ -6,16 +6,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1" 6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9" 7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8 8
9
10inherit module qoriq_build_64bit_kernel 9inherit module qoriq_build_64bit_kernel
11 10do_configure[depends] += "virtual/kernel:do_shared_workdir"
12S = "${WORKDIR}/git/asfmodule" 11S = "${WORKDIR}/git/asfmodule"
13 12
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" 13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}" 14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16
17INHIBIT_PACKAGE_STRIP = "1" 15INHIBIT_PACKAGE_STRIP = "1"
18 16
17do_configure_append (){
18 cp ${STAGING_KERNEL_BUILDDIR}/.config ${STAGING_KERNEL_DIR}/
19}
20
19do_install(){ 21do_install(){
20 install -d ${D}/${libexecdir} 22 install -d ${D}/${libexecdir}
21 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf 23 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
@@ -26,4 +28,3 @@ do_install(){
26 28
27FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf" 29FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
28RDEPENDS_${PN} += "ipsec-tools" 30RDEPENDS_${PN} += "ipsec-tools"
29