summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-01 23:53:46 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-05-12 14:42:20 +0800
commit0455fe8964074ee94d677649195bbb0fd7d78a2b (patch)
tree77566aa9cecabc6335d28bfaa730ccb99b8d4903
parent1ec1358c112fbc9de9695ee36f47ab45b987b3eb (diff)
downloadmeta-fsl-ppc-0455fe8964074ee94d677649195bbb0fd7d78a2b.tar.gz
ceetm: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. ceetm Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 266261e..beaed31 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -14,6 +14,11 @@ S = "${WORKDIR}/git"
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" 14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}" 15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16 16
17do_configure[depends] += "virtual/kernel:do_shared_workdir"
18do_configure_prepend () {
19 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/ceetm_module/Makefile
20}
21
17do_install(){ 22do_install(){
18 mkdir -p ${D}/usr/driver/ceetm 23 mkdir -p ${D}/usr/driver/ceetm
19 mkdir -p ${D}/${libdir}/tc 24 mkdir -p ${D}/${libdir}/tc