summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-11-09 23:14:28 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-11-10 13:33:59 +0800
commitd9443cbd98f2d4717d84d8325fc6099f5a3e6a25 (patch)
treea1ec0404696dba0f2bbe9dac469e3470ec4220d1
parent84263d57fcada761a350015ce4d77fb91af54bf8 (diff)
downloadmeta-fsl-ppc-jethro.tar.gz
linux-qoriq: fix the kernel hang issue with gcc-5.2jethro
Backport a patch to fix the kernel hang issue when the uImage is built by gcc-5.2. The details can be found in https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5e95235 Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> (cherry picked from commit 95d9f9aba81ccdae53011ac8c6fbbc2605b9cedc)
-rw-r--r--recipes-kernel/linux/files/0001-powerpc-Align-TOC-to-256-bytes.patch37
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/0001-powerpc-Align-TOC-to-256-bytes.patch b/recipes-kernel/linux/files/0001-powerpc-Align-TOC-to-256-bytes.patch
new file mode 100644
index 0000000..2131c9d
--- /dev/null
+++ b/recipes-kernel/linux/files/0001-powerpc-Align-TOC-to-256-bytes.patch
@@ -0,0 +1,37 @@
1From 7d4d16a6ccdd6d965b84284262a67d5b63426d50 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Mon, 9 Nov 2015 04:36:29 -0600
4Subject: [PATCH] powerpc: Align TOC to 256 bytes
5
6Recent toolchains(gcc-5.2) force the TOC to be 256 byte aligned. We need
7to enforce this alignment in our linker script, otherwise pointers
8to our TOC variables (__toc_start, __prom_init_toc_start) could
9be incorrect.
10
11If they are bad, we die a few hundred instructions into boot.
12
13Upstream-Status: Backport
14
15Backport from https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5e95235
16
17Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
18---
19 arch/powerpc/kernel/vmlinux.lds.S | 2 ++
20 1 file changed, 2 insertions(+)
21
22diff --git a/arch/powerpc/kernel/vmlinux.lds.S b/arch/powerpc/kernel/vmlinux.lds.S
23index f096e72..3266864 100644
24--- a/arch/powerpc/kernel/vmlinux.lds.S
25+++ b/arch/powerpc/kernel/vmlinux.lds.S
26@@ -213,6 +213,8 @@ SECTIONS
27 *(.opd)
28 }
29
30+ . = ALIGN(256);
31+
32 .got : AT(ADDR(.got) - LOAD_OFFSET) {
33 __toc_start = .;
34 #ifndef CONFIG_RELOCATABLE
35--
362.3.3
37
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb
index 3e0ab95..118c69b 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bb
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bb
@@ -3,5 +3,6 @@ require recipes-kernel/linux/linux-qoriq.inc
3SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \ 3SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
4 file://modify-defconfig-t1040-nr-cpus.patch \ 4 file://modify-defconfig-t1040-nr-cpus.patch \
5 file://net-sctp-CVE-2014-0101.patch \ 5 file://net-sctp-CVE-2014-0101.patch \
6 file://0001-powerpc-Align-TOC-to-256-bytes.patch \
6" 7"
7SRCREV = "f488de6741d5ba805b9fe813d2ddf32368d3a888" 8SRCREV = "f488de6741d5ba805b9fe813d2ddf32368d3a888"