summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-17 22:10:24 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:52 +0800
commitf60ef436641acf8011797893d130b90071cb934b (patch)
tree2a3f0b5be100e13b17f2c200bc7564f44be30cde
parent54e29fb388d9cae3a800093b0e51ce6bfb262629 (diff)
downloadmeta-fsl-ppc-f60ef436641acf8011797893d130b90071cb934b.tar.gz
mux-server: deploy the binary as it is standalone
The topaz mux-server is a standalone tool, deploy the binary like other images like u-boot/kernel/rcw. Signed-off-by: Ting Liu <ting.liu@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
index 5382f23..744a84c 100644
--- a/recipes-virtualization/mux-server/mux-server_1.02.bb
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -10,9 +10,18 @@ S = "${WORKDIR}/git"
10 10
11EXTRA_OEMAKE='HOSTCC="${CC}"' 11EXTRA_OEMAKE='HOSTCC="${CC}"'
12 12
13inherit deploy
14
13do_install () { 15do_install () {
14 install -d ${D}${bindir} 16 install -d ${D}${bindir}
15 install -m 755 mux_server ${D}${bindir} 17 install -m 755 mux_server ${D}${bindir}
16} 18}
17 19
20do_deploy() {
21 install -d ${DEPLOYDIR}/hv
22 install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR}
23 ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server
24}
25addtask deploy after do_install
26
18BBCLASSEXTEND = "native nativesdk" 27BBCLASSEXTEND = "native nativesdk"