summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-17 13:00:24 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:53 +0800
commita8152d1fb721a47243e013f0c75000698309ace6 (patch)
tree21ac64e63adf1884821db23285de6fb1d7f9e57c
parenta4a95db859aa9cbe5211b54e56797f07ce5ff610 (diff)
downloadmeta-fsl-ppc-a8152d1fb721a47243e013f0c75000698309ace6.tar.gz
pkc-host: update to revision 564f535
The changes include: - bc is added as a runtime dependency for performance tests - mini_calc is dropped and replaced by bc - use 'oe_runmake modules_install' to install kernel modules There are 138 new git commits. For detailed info, see: http://git.freescale.com/git/cgit.cgi/ppc/sdk/pkc-host.git/tag/?id=fsl-sdk-v1.8 Signed-off-by: Ting Liu <ting.liu@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/pkc-host/pkc-host_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-kernel/pkc-host/pkc-host_git.bb b/recipes-kernel/pkc-host/pkc-host_git.bb
index 2d5e316..3bf548f 100644
--- a/recipes-kernel/pkc-host/pkc-host_git.bb
+++ b/recipes-kernel/pkc-host/pkc-host_git.bb
@@ -4,30 +4,32 @@ LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03" 4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03"
5 5
6inherit module qoriq_build_64bit_kernel 6inherit module qoriq_build_64bit_kernel
7RDEPENDS_${PN} += "cryptodev-module" 7RDEPENDS_${PN} += "cryptodev-module bc"
8 8
9# Currently pkc-host does not support RSA_KEYGEN, remove this 9# Currently pkc-host does not support RSA_KEYGEN, remove this
10# if it is fixed. 10# if it is fixed.
11REQUIRED_DISTRO_FEATURES = "c29x_pkc" 11REQUIRED_DISTRO_FEATURES = "c29x_pkc"
12 12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1" 13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1"
14SRCREV = "cae512c94e2a26cc6b0d6393d307cdea2d7282c9" 14SRCREV = "564f535d596f43eb2901a7ff77bbe529a118c16e"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 18EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
19 19
20do_install() { 20do_install() {
21 install -d ${D}/lib/modules/c2x0 21 oe_runmake INSTALL_MOD_PATH="${D}" modules_install
22 install -d ${D}/etc/crypto 22 install -d ${D}/etc/crypto
23 install -d ${D}/${bindir} 23 install -d ${D}/${bindir}
24 cp ${S}/*.ko ${D}/lib/modules/c2x0
25 cp ${S}/crypto.cfg ${D}/etc/crypto 24 cp ${S}/crypto.cfg ${D}/etc/crypto
26 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto 25 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto
27 cp ${S}/perf/mini_calc/mini_calc ${D}/${bindir}
28 cp ${S}/apps/cli/cli ${D}/${bindir} 26 cp ${S}/apps/cli/cli ${D}/${bindir}
29 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir} 27 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir}
30} 28}
31 29
32 30
33FILES_${PN} += "${bindir}/mini_calc ${bindir}/cli ${bindir}/c29x_driver_perf_profile.sh /etc/crypto/crypto.cfg /etc/crypto/pkc-firmware.bin" 31FILES_${PN} = "${bindir}/cli \
32 ${bindir}/c29x_driver_perf_profile.sh \
33 /etc/crypto/crypto.cfg \
34 /etc/crypto/pkc-firmware.bin \
35"