summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-17 13:00:21 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:53 +0800
commit9f81be25948d13b7cf099a21d97e40649f69474d (patch)
treeafc4d155d031c1f678384143cefe54b7019f60c0
parent83fc57de72d8b901e3a86d5153699ecc20dfe8f2 (diff)
downloadmeta-fsl-ppc-9f81be25948d13b7cf099a21d97e40649f69474d.tar.gz
uio-seville: update to revision 80de832
This imports the following changes: 80de832 Fix Copyright issues 0c9921f Add support for interrupts on PHYs connected to seville's ports 53de571 fix: Avoid memory leak 6cf2d52 Refractoring uio_seville_main.c file 7b2ccba Fix: Use Seville register when flushing, not remapper's register d347b98 Beautify: Replace big switch() with a 2-line for() f8c8249 Beautify: Fix for() alignment fdde45d Fix: Pad undersized injected CPU control frames 3b9cff6 Fix: Typo for "reciving" 052d776 Fix: Assure that there can't be 2 processes that open the uio device 3c29b27 Fix: Interrupts might occur when /dev/npi is closing 59e3d2e Fix: Assure that only one thread is allowed to inject a frame at a time b96827c Fix: Assure that only one thread may extract a CPU frame at a time 8c9c47e Fix: Remove unecessary check for data in the polling function a202daf Fix: L2 Switch interrupt handler is called twice for each packet 985d4c2 Fix: dev/npi might be opened by two applications 3ecb8f3 Fix: Fix initialization of valiables for struct dev_npi dd74172 Beautify: Add ':' at the end of npi_read_q in description aceb6be Beautify: function do_control_frame_extr_dev() has duplicated code 262876b Beautify: Remove unnecessary macro d737cd8 Fix: Treat interrupts only from group 0 181ae15 Beautify: Rename variable leftovers_start to leftovers_begin Signed-off-by: Ting Liu <ting.liu@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rwxr-xr-xrecipes-kernel/uio-seville/uio-seville_0.1.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-kernel/uio-seville/uio-seville_0.1.bb b/recipes-kernel/uio-seville/uio-seville_0.1.bb
index 51e1475..7ca4c8f 100755
--- a/recipes-kernel/uio-seville/uio-seville_0.1.bb
+++ b/recipes-kernel/uio-seville/uio-seville_0.1.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "UIO driver for T1040 L2 Switch"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4 4
5SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git;branch=sdk-v1.7.x" 5SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git;branch=master"
6SRCREV = "35af73f3ba00745777f32787400d9eb0317d7ff5" 6SRCREV = "80de8322d0ab8c28f5dfbe3cde8759a1efbe06c9"
7 7
8inherit module 8inherit module
9 9
@@ -12,4 +12,3 @@ S = "${WORKDIR}/git/uio-driver"
12COMPATIBLE_MACHINE ?= "(none)" 12COMPATIBLE_MACHINE ?= "(none)"
13COMPATIBLE_MACHINE_t1040 = ".*" 13COMPATIBLE_MACHINE_t1040 = ".*"
14COMPATIBLE_MACHINE_t1042 = ".*" 14COMPATIBLE_MACHINE_t1042 = ".*"
15