summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-17 13:36:45 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:55 +0800
commit9a3b2ffb915db39ba5cda9fb6721cd82d8cecbb6 (patch)
treed94b521f921b58cd06ad9c25afa5636ec0542a9f
parentb8d1bc6a24f71b4526396aae13467f16537874d1 (diff)
downloadmeta-fsl-ppc-9a3b2ffb915db39ba5cda9fb6721cd82d8cecbb6.tar.gz
rcw: update to revision 426f7a6
This imports following changes: 426f7a6 SECURE BOOT: Add missing RCW's for T4240QDS 756454f SECURE BOOT: Rename the RCW's 7782087 SECURE BOOT: Remove Unwanted RCW's e93c210 LS1021: Unset BOOT_HO bit in rcw. 4375fc4 t1023rdb: update IFC_MODE to 0x2F for errata A-009138 5cf9bc5 T4240QDS: Add four 1800MHz/Core RCW files for T4240QDS board cff536a t1023rdb: set RTC=1 to enable GPIO1[14] a5983f2 T4240RDB: Add one new RCW for T4240RDB board 3a6ae48 ls1021a: fix some serdes settings for SATA 31078e1 ls1021atwr: do not power down PLL which is used by SATA c6d72e3 t2080qds: rcw: Add eMMC DDR mode RCW c77415c T104xD4RDB: update SRDS_PLL_REF_CLK_SEL_S1 value e2c0844 ls1021atwr: add USB 2.0 support fd0c1df p5020/p5040: NAND Secure Boot RCW added with PBI commands 259d57d t1023rdb: add rcw for t1023rdb board c3ab906 T1042: Add t1042d4rdb rcw files for serdes protocol 0x86 ae39560 T1040: Add t1040d4rdb rcw files for serdes protocol 0x66 b9d3c22 p3041: NAND Secure Boot RCW added with PBI commands dc0fad9 t2080rdb: update ddr to 1866MT/s 03c5ee6 t2080: update platform clock to 600MHz 72945fa rcw: ls102xa: merge rcw for lpuart and dcu 6678741 rcw: ls102xa: Adjust the features supported in SD boot f7a54c1 arm: ls102xa: Increase IO drive strength for LS1021AQDS board 3dd07fa B4860-As-B3: Add two new RCW files 69a041c B4860QDS: Add HWA_CGA_M3_CLK_SEL bits define in b4860.rcwi file 87289d5 ls102xa: rcw: Add QSPI boot RCW for LS1021A TWR board 13bf692 t1024: update FM1_MAC_RAT from 0 to 1 5b94b3e t1024rdb: add new rcw 0x135 and minor update Also align with the one in meta-fsl-arm layer. Signed-off-by: Ting Liu <ting.liu@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch57
-rw-r--r--recipes-bsp/rcw/rcw_git.bb37
2 files changed, 70 insertions, 24 deletions
diff --git a/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
new file mode 100644
index 0000000..49d99fc
--- /dev/null
+++ b/recipes-bsp/rcw/rcw/rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch
@@ -0,0 +1,57 @@
1From f2e796c903b2a3f81dbd38da3dc087cb7539d307 Mon Sep 17 00:00:00 2001
2From: Zhenhua Luo <zhenhua.luo@freescale.com>
3Date: Wed, 3 Sep 2014 03:03:42 -0500
4Subject: [PATCH] Makefile: make BOARDS/DESTDIR overidable and add endian
5 switch
6
71. For one specific board, no need to build the rcw for all supported
8 targets, make BOARDS and DESTDIR overridable to achieve this.
92. Add the endian swap for qspiboot rcw
10
11Upstream-Status: Pending
12
13Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
14---
15 Makefile | 4 ++--
16 Makefile.inc | 9 +++++++--
17 2 files changed, 9 insertions(+), 4 deletions(-)
18
19diff --git a/Makefile b/Makefile
20index 6ec1697..0f94293 100644
21--- a/Makefile
22+++ b/Makefile
23@@ -1,5 +1,5 @@
24-DESTDIR = .
25-BOARDS = b4420qds b4860qds \
26+DESTDIR ?= .
27+BOARDS ?= b4420qds b4860qds \
28 ls1021aqds ls1021atwr \
29 p2041rdb p3041ds p4080ds p5020ds p5040ds \
30 t1024qds t1023rdb t1024rdb t1040rdb t1042rdb t1042rdb_pi t1040qds \
31diff --git a/Makefile.inc b/Makefile.inc
32index 4cadb2e..6e8b78f 100644
33--- a/Makefile.inc
34+++ b/Makefile.inc
35@@ -1,4 +1,4 @@
36-DESTDIR = .
37+DESTDIR ?= .
38 INSTALL = install
39 PYTHON ?= python2
40 RCW = $(PYTHON) ../rcw.py
41@@ -18,7 +18,12 @@ all: $(targets)
42 install: $(targets)
43 $(INSTALL) -d $(DESTDIR)
44 @for file in $^; do \
45- $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
46+ case $$file in \
47+ *qspiboot*) file_swap="`echo $$file | sed -e 's/qspiboot/qspiboot_swap/'`"; \
48+ tclsh byte_swap.tcl $$file $$file_swap 8 ; \
49+ $(INSTALL) -m 644 -D $$file_swap $(DESTDIR)/$$file_swap ;; \
50+ *) $(INSTALL) -m 644 -D $$file $(DESTDIR)/$$file; \
51+ esac \
52 done
53 $(INSTALL) -m 644 -D README $(DESTDIR)
54
55--
561.7.9.7
57
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 5714ed0..57f305a 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,47 +1,36 @@
1DESCRIPTION = "Reset Control Words (RCW)" 1SUMMARY = "Reset Configuration Word"
2SECTION = "rcw" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "BSD"
4PR = "r8" 4PR = "r8"
5 5
6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" 6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
7 7
8# this package is specific to the machine itself
9INHIBIT_DEFAULT_DEPS = "1"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12inherit deploy 8inherit deploy
13 9
14SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;nobranch=1" 10SRCBRANCH = "master"
15SRCREV = "3e89f378ed70e9b856756de8c3dbdfccb045fa0c" 11SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2"
12SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \
13 file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
14"
16 15
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19export PYTHON 18EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
20 19
21do_install () { 20do_install () {
22 make install 21 oe_runmake install
23
24 M=`echo ${MACHINE} | sed s/-64b//g`
25 if [ "t1042rdb" = "${M}" ] || [ "t1042rdb-pi" = "${M}" ];then
26 M=t1042rdb_pi
27 fi
28 install -d ${D}/boot/rcw
29 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
30} 22}
31 23
32do_deploy () { 24do_deploy () {
33 M=`echo ${MACHINE} | sed s/-64b//g`
34 if [ "t1042rdb" = "${M}" ] || [ "t1042rdb-pi" = "${M}" ];then
35 M=t1042rdb_pi
36 fi
37 install -d ${DEPLOYDIR}/rcw 25 install -d ${DEPLOYDIR}/rcw
38 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw 26 cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
39} 27}
40addtask deploy after do_install 28addtask deploy after do_install
41 29
42PACKAGES += "${PN}-image" 30PACKAGES += "${PN}-image"
43FILES_${PN}-image += "/boot" 31FILES_${PN}-image += "/boot"
44 32
45COMPATIBLE_HOST_qoriq-ppc = ".*"
46COMPATIBLE_HOST ?= "(none)"
47ALLOW_EMPTY_${PN} = "1" 33ALLOW_EMPTY_${PN} = "1"
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(qoriq-ppc)"