summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-01 23:54:00 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-05-12 16:24:34 +0800
commit92e6964c1364fe0c9ee680b0dfa585810b5125c0 (patch)
tree5b04bc999e516572c2cf481edf55aa358964ed8a
parent4c8cd553f9de56379e2b6502ceb996521e2d6a20 (diff)
downloadmeta-fsl-ppc-92e6964c1364fe0c9ee680b0dfa585810b5125c0.tar.gz
asf: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. asf Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--recipes-kernel/asf/asf_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
index 8070f5a..1ca4c8e 100644
--- a/recipes-kernel/asf/asf_git.bb
+++ b/recipes-kernel/asf/asf_git.bb
@@ -6,7 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1" 6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9" 7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8 8
9
10inherit module qoriq_build_64bit_kernel 9inherit module qoriq_build_64bit_kernel
11 10
12S = "${WORKDIR}/git/asfmodule" 11S = "${WORKDIR}/git/asfmodule"
@@ -16,6 +15,11 @@ export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16 15
17INHIBIT_PACKAGE_STRIP = "1" 16INHIBIT_PACKAGE_STRIP = "1"
18 17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/Makefile
21}
22
19do_install(){ 23do_install(){
20 install -d ${D}/${libexecdir} 24 install -d ${D}/${libexecdir}
21 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf 25 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf