summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSona Sarmadi <sona.sarmadi@enea.com>2015-03-02 11:44:00 +0100
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-03-06 16:28:59 +0800
commit7e2b2203ce7569e5721f4621edca1d17375a78b4 (patch)
tree3e24073f436cf08853a927e4ae571d21c567c1ba
parent19a183db9d8ac539b2640204ef01afa0b7d9a13e (diff)
downloadmeta-fsl-ppc-7e2b2203ce7569e5721f4621edca1d17375a78b4.tar.gz
security-keys: CVE-2014-9529
Fixes memory corruption or panic during key garbage collection Reference: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9529 Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
-rw-r--r--recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch53
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bb1
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch b/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch
new file mode 100644
index 0000000..573b530
--- /dev/null
+++ b/recipes-kernel/linux/files/security-keys-CVE-2014-9529.patch
@@ -0,0 +1,53 @@
1From a7033e302dcd38bb4333f46b3fdcd930955e402d Mon Sep 17 00:00:00 2001
2From: Sasha Levin <sasha.levin@oracle.com>
3Date: Mon, 29 Dec 2014 09:39:01 -0500
4Subject: [PATCH] KEYS: close race between key lookup and freeing
5
6commit a3a8784454692dd72e5d5d34dcdab17b4420e74c upstream.
7
8When a key is being garbage collected, it's key->user would get put before
9the ->destroy() callback is called, where the key is removed from it's
10respective tracking structures.
11
12This leaves a key hanging in a semi-invalid state which leaves a window open
13for a different task to try an access key->user. An example is
14find_keyring_by_name() which would dereference key->user for a key that is
15in the process of being garbage collected (where key->user was freed but
16->destroy() wasn't called yet - so it's still present in the linked list).
17
18This would cause either a panic, or corrupt memory.
19
20Fixes CVE-2014-9529.
21
22Upstream-Status: Backport
23
24Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
25Signed-off-by: David Howells <dhowells@redhat.com>
26Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
27Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
28---
29 security/keys/gc.c | 4 ++--
30 1 file changed, 2 insertions(+), 2 deletions(-)
31
32diff --git a/security/keys/gc.c b/security/keys/gc.c
33index d67c97b..7978186 100644
34--- a/security/keys/gc.c
35+++ b/security/keys/gc.c
36@@ -201,12 +201,12 @@ static noinline void key_gc_unused_keys(struct list_head *keys)
37 if (test_bit(KEY_FLAG_INSTANTIATED, &key->flags))
38 atomic_dec(&key->user->nikeys);
39
40- key_user_put(key->user);
41-
42 /* now throw away the key memory */
43 if (key->type->destroy)
44 key->type->destroy(key);
45
46+ key_user_put(key->user);
47+
48 kfree(key->description);
49
50 #ifdef KEY_DEBUGGING
51--
521.9.1
53
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb
index e7af627..f082b04 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bb
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
36 file://0003-shmem-CVE-2014-4171.patch \ 36 file://0003-shmem-CVE-2014-4171.patch \
37 file://fs-CVE-2014-4014.patch \ 37 file://fs-CVE-2014-4014.patch \
38 file://tracing-CVE-2014-7825_CVE-2014-7826.patch \ 38 file://tracing-CVE-2014-7825_CVE-2014-7826.patch \
39 file://security-keys-CVE-2014-9529.patch \
39" 40"
40SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229" 41SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229"
41 42