summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-13 18:15:51 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:51 +0800
commit49082434e30786a78484ede09104100ff1508e03 (patch)
treedc1b038066063c8a44c8dff6a7f7e13b56e68137
parent0f841bfa0daba4789b8723c565d9103a68815c2f (diff)
downloadmeta-fsl-ppc-49082434e30786a78484ede09104100ff1508e03.tar.gz
auto-resp: fix the include path to private headers
When building external module, $(PWD) is the root of the kernel tree. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--recipes-kernel/auto-resp/ar_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-kernel/auto-resp/ar_git.bb b/recipes-kernel/auto-resp/ar_git.bb
index 81a94a0..52d9f57 100644
--- a/recipes-kernel/auto-resp/ar_git.bb
+++ b/recipes-kernel/auto-resp/ar_git.bb
@@ -14,6 +14,10 @@ export KERNEL_PATH
14 14
15INHIBIT_PACKAGE_STRIP = "1" 15INHIBIT_PACKAGE_STRIP = "1"
16 16
17do_compile_prepend() {
18 sed -i -e 's,EXTRA_CFLAGS += -I$(PWD),EXTRA_CFLAGS += -I${S},' ${S}/armodule/source/Makefile
19}
20
17do_install(){ 21do_install(){
18 install -d ${D}/lib/modules/${KERNEL_VERSION} 22 install -d ${D}/lib/modules/${KERNEL_VERSION}
19 install -d ${D}${bindir} 23 install -d ${D}${bindir}