summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Stoica <cristian.stoica@freescale.com>2015-07-17 17:29:42 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:38:00 +0800
commit1d729c77e7aadc0cb90cc4c1ad6401c38408899e (patch)
treedc5ea65beb0fc5c9cf2768a58a0891cd5a26620a
parent61d195bbab0b5852593598ba291ee9429a2ac9ba (diff)
downloadmeta-fsl-ppc-1d729c77e7aadc0cb90cc4c1ad6401c38408899e.tar.gz
openssl: rewrite recipe to remove code duplication
- the package is now based on upstream tarball instead of Freescale git repository - Freescale cryptodev patches are applied only on target package to avoid build errors Signed-off-by: Cristian Stoica <cristian.stoica@freescale.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bb5
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bbappend34
2 files changed, 4 insertions, 35 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bb b/recipes-connectivity/openssl/openssl_1.0.1i.bb
index 54c052e..9d093ef 100644
--- a/recipes-connectivity/openssl/openssl_1.0.1i.bb
+++ b/recipes-connectivity/openssl/openssl_1.0.1i.bb
@@ -26,7 +26,6 @@ SRC_URI += "file://configure-targets.patch \
26 file://debian/no-symbolic.patch \ 26 file://debian/no-symbolic.patch \
27 file://debian/debian-targets.patch \ 27 file://debian/debian-targets.patch \
28 file://openssl_fix_for_x32.patch \ 28 file://openssl_fix_for_x32.patch \
29 file://openssl-fix-doc.patch \
30 file://fix-cipher-des-ede3-cfb1.patch \ 29 file://fix-cipher-des-ede3-cfb1.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \ 30 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
32 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \ 31 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
@@ -35,8 +34,8 @@ SRC_URI += "file://configure-targets.patch \
35 file://openssl-fix-des.pod-error.patch \ 34 file://openssl-fix-des.pod-error.patch \
36 " 35 "
37 36
38SRC_URI[md5sum] = "de62b43dfcd858e66a74bee1c834e959" 37SRC_URI[md5sum] = "c8dc151a671b9b92ff3e4c118b174972"
39SRC_URI[sha256sum] = "53cb818c3b90e507a8348f4f5eaedb05d8bfe5358aabb508b7263cc670c3e028" 38SRC_URI[sha256sum] = "3c179f46ca77069a6a0bac70212a9b3b838b2f66129cb52d568837fc79d8fcc7"
40 39
41PACKAGES =+ " \ 40PACKAGES =+ " \
42 ${PN}-engines-dbg \ 41 ${PN}-engines-dbg \
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
index 89d7339..2fa098f 100644
--- a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
+++ b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
@@ -2,10 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/openssl-fsl:"
2 2
3RDEPENDS_${PN}_class-target += "cryptodev-module" 3RDEPENDS_${PN}_class-target += "cryptodev-module"
4 4
5# base package is taken from Freescale repository 5SRC_URI_append_class-target = " file://0001-remove-double-initialization-of-cryptodev-engine.patch \
6SRCBRANCH = "OpenSSL_1_0_1-stable"
7SRC_URI = "git://git.openssl.org/openssl.git;branch=${SRCBRANCH} \
8 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
9 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \ 6 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
10 file://0003-cryptodev-fix-algorithm-registration.patch \ 7 file://0003-cryptodev-fix-algorithm-registration.patch \
11 file://0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \ 8 file://0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \
@@ -23,33 +20,6 @@ SRC_URI = "git://git.openssl.org/openssl.git;branch=${SRCBRANCH} \
23 file://0016-Fixed-DH-keygen-pair-generator.patch \ 20 file://0016-Fixed-DH-keygen-pair-generator.patch \
24 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \ 21 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
25" 22"
26SRCREV = "2b456034457b58454aae3998a2765b6a5b9bc837"
27
28SRC_URI += "file://configure-targets.patch \
29 file://shared-libs.patch \
30 file://oe-ldflags.patch \
31 file://engines-install-in-libdir-ssl.patch \
32 file://openssl-fix-link.patch \
33 file://debian/version-script.patch \
34 file://debian/pic.patch \
35 file://debian/c_rehash-compat.patch \
36 file://debian/ca.patch \
37 file://debian/make-targets.patch \
38 file://debian/no-rpath.patch \
39 file://debian/man-dir.patch \
40 file://debian/man-section.patch \
41 file://debian/no-symbolic.patch \
42 file://debian/debian-targets.patch \
43 file://openssl_fix_for_x32.patch \
44 file://fix-cipher-des-ede3-cfb1.patch \
45 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
46 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
47 file://initial-aarch64-bits.patch \
48 file://find.pl \
49 file://openssl-fix-des.pod-error.patch \
50 "
51S = "${WORKDIR}/git"
52
53# Digest offloading through cryptodev is not recommended because of the 23# Digest offloading through cryptodev is not recommended because of the
54# performance penalty of the Openssl engine interface. Openssl generates a huge 24# performance penalty of the Openssl engine interface. Openssl generates a huge
55# number of calls to digest functions for even a small amount of work data. 25# number of calls to digest functions for even a small amount of work data.
@@ -57,4 +27,4 @@ S = "${WORKDIR}/git"
57# when downloading only 10 files of 700 bytes each. 27# when downloading only 10 files of 700 bytes each.
58# Do not build OpenSSL with cryptodev digest support until engine digest 28# Do not build OpenSSL with cryptodev digest support until engine digest
59# interface gets some rework: 29# interface gets some rework:
60CFLAG := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}" 30CFLAG_class-target := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"