summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiu Ting-B28495 <ting.liu@freescale.com>2015-05-13 18:15:50 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-07-22 17:37:51 +0800
commit0f841bfa0daba4789b8723c565d9103a68815c2f (patch)
treef3789bb4b08531476b6ebb6a424ebf04885b92d3
parenta39e188c9b213ad3d7f43fce7de1140e1b02a657 (diff)
downloadmeta-fsl-ppc-0f841bfa0daba4789b8723c565d9103a68815c2f.tar.gz
ipc: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. ipc Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Liu Ting-B28495 <ting.liu@freescale.com>
-rw-r--r--recipes-kernel/ipc/ipc-modules.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-kernel/ipc/ipc-modules.inc b/recipes-kernel/ipc/ipc-modules.inc
index e403e6b..79ba7ef 100644
--- a/recipes-kernel/ipc/ipc-modules.inc
+++ b/recipes-kernel/ipc/ipc-modules.inc
@@ -9,6 +9,11 @@ inherit module qoriq_build_64bit_kernel
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12do_configure[depends] += "virtual/kernel:do_shared_workdir"
13do_configure_prepend() {
14 sed -i 's,$(KERNEL_DIR)/.config,$(KBUILD_OUTPUT)/.config,' ${S}/kernel/Makefile
15}
16
12do_compile_prepend () { 17do_compile_prepend () {
13 cd ${S}/kernel 18 cd ${S}/kernel
14 case ${MACHINE} in 19 case ${MACHINE} in