summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2015-01-13 18:27:37 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-14 10:44:02 +0800
commitfe0429ee9f6f719e98c4c3aa5fe066c7ff802b3b (patch)
treee4379e745a171994b93f59adaed98b03ca871fe4
parent4eceb12909f7f34cb5a7118dd3a7824d34e269cf (diff)
downloadmeta-fsl-ppc-fe0429ee9f6f719e98c4c3aa5fe066c7ff802b3b.tar.gz
auto-resp: add recipe
Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--recipes-kernel/auto-resp/ar_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/auto-resp/ar_git.bb b/recipes-kernel/auto-resp/ar_git.bb
new file mode 100644
index 0000000..81a94a0
--- /dev/null
+++ b/recipes-kernel/auto-resp/ar_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Auto Response Control Module"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5inherit module
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/auto-resp.git;branch=sdk-v1.7.x"
8SRCREV = "dbede76fb4020a370baa393f7c53af4c0db8f175"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
13export KERNEL_PATH
14
15INHIBIT_PACKAGE_STRIP = "1"
16
17do_install(){
18 install -d ${D}/lib/modules/${KERNEL_VERSION}
19 install -d ${D}${bindir}
20 install -m 644 ${B}/bin/ar.ko ${D}/lib/modules/${KERNEL_VERSION}/
21 cp -f ${S}/bin/ar_* ${D}${bindir}/
22}
23
24FILES_${PN} += "${bindir}/"
25