summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Schmitt <B43082@freescale.com>2015-01-09 17:09:09 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-12 16:56:06 +0800
commitcb0f22c02ae5b1464e53008a9d1c75bbc0e9a8dc (patch)
tree034090e1f1f790a6fb5264f8b4d57695f571302e
parent7d08d97643bf36395fa1a8550e1f82081132eddb (diff)
downloadmeta-fsl-ppc-cb0f22c02ae5b1464e53008a9d1c75bbc0e9a8dc.tar.gz
uio-seville: update to revision 35af73f
This includes following fixes: 35af73f Fix: Copy user-space buffer of injected control frame to kernel 00c8040 Add multiple error labels in the probe function 2835689 Fix: Remove memory leaks when the module is removed or fails on probing d770a37 Fix: Remove compile warning on 32b 89e29fc Fix: Remove unnecessary checks adbb47e Beautify: Rename macros into more proper names d5cac6e Add "poll()" function for NPI device 220cee3 Replace rescheduling with work queues 2a5fe4e Add cacheline support for extraction of control frames 6f14f0b Fix: UIO device might not be removed properly if module fails to initialize 2dcea55 Removed unecessary includes 1077880 Add UIO driver 68ab7bd Initial empty repository update COMPATIBLE_MACHINE to use soc_family. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rwxr-xr-xrecipes-kernel/uio-seville/uio-seville_0.1.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-kernel/uio-seville/uio-seville_0.1.bb b/recipes-kernel/uio-seville/uio-seville_0.1.bb
index 0307a6d..51e1475 100755
--- a/recipes-kernel/uio-seville/uio-seville_0.1.bb
+++ b/recipes-kernel/uio-seville/uio-seville_0.1.bb
@@ -2,11 +2,14 @@ DESCRIPTION = "UIO driver for T1040 L2 Switch"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" 3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4 4
5SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git" 5SRC_URI = "git://git.freescale.com/ppc/sdk/l2switch-uio.git;branch=sdk-v1.7.x"
6SRCREV = "1077880ff3557d44dc5dd9fe5e2f4ee1474fb25f" 6SRCREV = "35af73f3ba00745777f32787400d9eb0317d7ff5"
7 7
8inherit module 8inherit module
9 9
10S = "${WORKDIR}/git/uio-driver" 10S = "${WORKDIR}/git/uio-driver"
11 11
12COMPATIBLE_MACHINE = "(t1040qds|t1040rdb|t1040rdb-64b)" 12COMPATIBLE_MACHINE ?= "(none)"
13COMPATIBLE_MACHINE_t1040 = ".*"
14COMPATIBLE_MACHINE_t1042 = ".*"
15