summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-01-07 12:33:23 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-08 18:07:42 +0800
commitb2d372a4ea18d79999498efdb57468d130c3926e (patch)
tree6dc06867cf591682450f9e1f0d0f0b7739e03b9f
parent6eae8bc22022866e099f5f4a5bc56b6e246e2fe8 (diff)
downloadmeta-fsl-ppc-b2d372a4ea18d79999498efdb57468d130c3926e.tar.gz
fm-ucode: use soc_family to match deployed binaries
listing machine names in recipe is painful when adding support for boards with same soc. use soc_family instead. Signed-off-by: Ting Liu <ting.liu@freescale.com>
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb29
1 files changed, 8 insertions, 21 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
index ef9cae0..9f8ac46 100644
--- a/recipes-dpaa/fm-ucode/fm-ucode_git.bb
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -12,33 +12,19 @@ SRCREV = "517267e5f9ca9ab13cb2e94e0a20f555f73885ee"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15ALLOW_EMPTY_${PN} = "1" 15REGLEX ?= "${MACHINE}"
16REGLEX_t1042 = "t1040"
17REGLEX_b4420 = "b4860"
18REGLEX_t4160 = "t4240"
19
16do_install () { 20do_install () {
17 case ${MACHINE} in 21 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
18 t1040qds|t1040qds-64b|t1040rdb|t1040rdb-64b|t1042rdb|t1042rdb-64b) UCODE=t1040;;
19 t2080qds|t2080qds-64b|t2080rdb|t2080rdb-64b) UCODE=t2080;;
20 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860;;
21 t4240qds|t4240qds-64b|t4240rdb|t4240rdb-64b|t4160qds|t4160qds-64b) UCODE=t4240;;
22 p5020ds|p5020ds-64b) UCODE=p5020;;
23 p5040ds|p5040ds-64b) UCODE=p5040;;
24 *) UCODE=${MACHINE};;
25 esac
26 UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'`
27 install -d ${D}/boot 22 install -d ${D}/boot
28 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/ 23 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/
29} 24}
30 25
31do_deploy () { 26do_deploy () {
32 case ${MACHINE} in 27 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
33 t1040qds|t1040qds-64b|t1040rdb|t1040rdb-64b|t1042rdb|t1042rdb-64b) UCODE=t1040;;
34 t2080qds|t2080qds-64b|t2080rdb|t2080rdb-64b) UCODE=t2080;;
35 b4420qds|b4420qds-64b|b4860qds|b4860qds-64b) UCODE=b4860;;
36 t4240qds|t4240qds-64b|t4240rdb|t4240rdb-64b|t4160qds|t4160qds-64b) UCODE=t4240;;
37 p5020ds|p5020ds-64b) UCODE=p5020;;
38 p5040ds|p5040ds-64b) UCODE=p5040;;
39 *) UCODE=${MACHINE};;
40 esac
41 UCODE=`echo $UCODE | sed -e 's,[a-zA-Z]*$,,'`
42 install -d ${DEPLOYDIR}/ 28 install -d ${DEPLOYDIR}/
43 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/ 29 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/
44} 30}
@@ -46,5 +32,6 @@ addtask deploy before do_build after do_install
46 32
47PACKAGES += "${PN}-image" 33PACKAGES += "${PN}-image"
48FILES_${PN}-image += "/boot" 34FILES_${PN}-image += "/boot"
35ALLOW_EMPTY_${PN} = "1"
49COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)" 36COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)"
50 37