summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-10-14 05:49:16 -0500
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-10-14 19:15:45 +0800
commit23af7623411731ab63152703d48ed2c8c3931668 (patch)
tree84edb8ecbd85e01c2186a2711e44c0000095b69f
parent4c72009bdad40dcffe994ca1e43e4ed0151989ca (diff)
downloadmeta-fsl-ppc-23af7623411731ab63152703d48ed2c8c3931668.tar.gz
skmm-ep: adjust the LIBEDIT_CFLAGS and LIBEDIT_LDFLAGS to fix build issue
Fix the following build error: | [CC] process.c (lib:skmm_process) | apps/pciep_dma/pciep_dma.c:37:37: fatal error: readline.h: No such file or directory | #include <readline.h> /* libedit */ | ^ | compilation terminated. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb14
1 files changed, 5 insertions, 9 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
index fcbd2ed..4fdba3f 100644
--- a/recipes-extended/skmm-ep/skmm-ep_git.bb
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -16,16 +16,12 @@ COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19EXTRA_OEMAKE = 'MACHINE=${MACHINE}' 19LIBEDIT_CFLAGS = "$(pkg-config --cflags libedit)"
20LIBEDIT_LDFLAGS = "$(pkg-config --libs --static libedit)"
20 21
21export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)" 22EXTRA_OEMAKE = 'ARCH=${TARGET_ARCH} MACHINE=${MACHINE} LIBEDIT_CFLAGS=${LIBEDIT_CFLAGS} \
22export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)" 23 LIBEDIT_LDFLAGS=${LIBEDIT_LDFLAGS} V=1'
23
24do_compile () {
25 export ARCH=${TARGET_ARCH}
26 oe_runmake
27}
28 24
29do_install () { 25do_install () {
30 oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D} 26 oe_runmake install DESTDIR=${D}
31} 27}