summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-01-07 17:55:07 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-08 18:21:55 +0800
commit0f720954b043c9d4f35bbbca2c1b12ebadd7a7cb (patch)
tree6f8825b491e44fc278fb2bf82f323dee0590013c
parent38fbafcb3b3592149c42ebe050a0483d3a515bc0 (diff)
downloadmeta-fsl-ppc-0f720954b043c9d4f35bbbca2c1b12ebadd7a7cb.tar.gz
asf: update revision to 16eb472
This update to fsl sdk v1.7 release. The detailed changes can be found at: http://git.freescale.com/git/cgit.cgi/ppc/sdk/asf.git/ Other changes to sync with meta-fsl-arm: * install kernel modules to ${D}/lib/modules/${KERNEL_VERSION}/asf * install scripts to ${D}/${libexecdir}/ * remove dependency on virtual/kernel as it inherit module.bbclass Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
-rw-r--r--recipes-kernel/asf/asf_git.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
index 9597257..8070f5a 100644
--- a/recipes-kernel/asf/asf_git.bb
+++ b/recipes-kernel/asf/asf_git.bb
@@ -4,10 +4,8 @@ LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" 4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5 5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1" 6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1"
7SRCREV = "f107bc7dac7fe74d765dc09f66dca84951921d2c" 7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8 8
9DEPENDS="virtual/kernel"
10RDEPENDS_${PN} += "ipsec-tools"
11 9
12inherit module qoriq_build_64bit_kernel 10inherit module qoriq_build_64bit_kernel
13 11
@@ -16,12 +14,16 @@ S = "${WORKDIR}/git/asfmodule"
16EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}" 14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
17export KERNEL_PATH = "${STAGING_KERNEL_DIR}" 15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
18 16
17INHIBIT_PACKAGE_STRIP = "1"
18
19do_install(){ 19do_install(){
20 mkdir -p ${D}/usr/driver/asf 20 install -d ${D}/${libexecdir}
21 cp -rf ${S}/bin/full ${D}/usr/driver/asf 21 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
22 cp -rf ${S}/bin/min ${D}/usr/driver/asf 22 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
23 cp -rf ${S}/../scripts ${D}/usr/driver/asf/. 23 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
24 cp -rf ${S}/../scripts ${D}/${libexecdir}/
24} 25}
25 26
26FILES_${PN} += "/usr/driver/asf" 27FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
27INHIBIT_PACKAGE_STRIP = "1" 28RDEPENDS_${PN} += "ipsec-tools"
29