summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-10-04 12:46:59 -0500
committerMatthew McClintock <msm@freescale.com>2011-10-04 12:46:59 -0500
commit8063d57e8e6287bfc3f12cf0cef13fdced9dc06b (patch)
treedce8c0e5cb4d1c12995175708e0c0b9b4a8a92dd
parent11dbb630f6f69584ed547b1e7bc5304d3fcde073 (diff)
downloadmeta-fsl-ppc-8063d57e8e6287bfc3f12cf0cef13fdced9dc06b.tar.gz
Initial commit for FSL Machines, Images, and Distro settings
Signed-off-by: Matthew McClintock <msm@freescale.com>
-rw-r--r--conf/distro/fsl.conf49
-rw-r--r--conf/layer.conf11
-rw-r--r--conf/machine/e500mc.inc20
-rw-r--r--conf/machine/e500v2.inc19
-rw-r--r--conf/machine/e5500-64b.inc20
-rw-r--r--conf/machine/e5500.inc20
-rw-r--r--conf/machine/mpc8572ds.conf7
-rw-r--r--conf/machine/p1020rdb.conf7
-rw-r--r--conf/machine/p1022ds.conf7
-rw-r--r--conf/machine/p2020ds.conf10
-rw-r--r--conf/machine/p3041ds.conf7
-rw-r--r--conf/machine/p4080ds.conf9
-rw-r--r--conf/machine/p5020ds-64b.conf7
-rw-r--r--conf/machine/p5020ds.conf7
-rw-r--r--images/fsl-image-lsb-sdk.bb11
-rw-r--r--images/fsl-image-lsb.bb9
-rw-r--r--images/fsl-image-minimal.bb15
17 files changed, 235 insertions, 0 deletions
diff --git a/conf/distro/fsl.conf b/conf/distro/fsl.conf
new file mode 100644
index 0000000..8b35b05
--- /dev/null
+++ b/conf/distro/fsl.conf
@@ -0,0 +1,49 @@
1DISTRO = "fsl"
2DISTRO_NAME = "Yocto (Built by Poky 5.0)"
3DISTRO_VERSION = "1.0+snapshot-${DATE}"
4SDK_VENDOR = "-fslsdk"
5SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
6
7MAINTAINER = "FSL <fsl@yoctoproject.org>"
8
9TARGET_VENDOR = "-fsl"
10
11LOCALCONF_VERSION = "1"
12
13DISTRO_FEATURES_append = " largefile opengl"
14
15SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${TARGET_ARCH}"
16SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
17
18DISTRO_EXTRA_RDEPENDS += "task-core-boot"
19DISTRO_EXTRA_RRECOMMENDS += ""
20
21POKYQEMUDEPS = "${@base_contains("INCOMPATIBLE_LICENSE", "GPLv3", "", "qemu-config",d)}"
22DISTRO_EXTRA_RDEPENDS_append_qemuarm = " ${POKYQEMUDEPS}"
23DISTRO_EXTRA_RDEPENDS_append_qemumips = " ${POKYQEMUDEPS}"
24DISTRO_EXTRA_RDEPENDS_append_qemuppc = " ${POKYQEMUDEPS}"
25DISTRO_EXTRA_RDEPENDS_append_qemux86 = " ${POKYQEMUDEPS}"
26DISTRO_EXTRA_RDEPENDS_append_qemux86-64 = " ${POKYQEMUDEPS}"
27
28TCLIBCAPPEND = ""
29
30QEMU_TARGETS ?= "arm i386 mips mipsel ppc x86_64"
31# Other QEMU_TARGETS "mips64 mips64el sh4"
32
33PREMIRRORS ?= "\
34bzr://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
35cvs://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
36git://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
37hg://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
38osc://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
39p4://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
40svk://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
41svn://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
42
43MIRRORS =+ "\
44ftp://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
45http://.*/.* http://autobuilder.yoctoproject.org/sources/ \n \
46https://.*/.* http://autobuilder.yoctoproject.org/sources/ \n"
47
48IMAGE_CLASSES = "image_types_uboot"
49
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..b469c67
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,11 @@
1# We have a packages directory, add to BBFILES
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*"
5BBFILES += "${LAYERDIR}/images/*.bb"
6
7BBFILE_COLLECTIONS += "fsl"
8BBFILE_PATTERN_fsl := "^${LAYERDIR}/"
9BBFILE_PRIORITY_fsl = "5"
10
11BB_ENV_EXTRAWHITE := "KSRC USRC"
diff --git a/conf/machine/e500mc.inc b/conf/machine/e500mc.inc
new file mode 100644
index 0000000..fbd7830
--- /dev/null
+++ b/conf/machine/e500mc.inc
@@ -0,0 +1,20 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce500mc.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_FEATURES_RRECOMMENDS = ""
7
8
9PREFERRED_PROVIDER_virtual/kernel = "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel = "3.0.1"
11PREFERRED_PROVIDER_linux-libc-headers = "linux-qoriq-sdk-headers"
12
13KERNEL_IMAGETYPE = "uImage"
14SERIAL_CONSOLE = "115200 ttyS0"
15IMAGE_FSTYPES = "tar.gz ext2.gz"
16# disable the images below for now
17# ext2.bz2 ext2.lzma \
18# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
19
20MACHINEOVERRIDES .= ":e500mc"
diff --git a/conf/machine/e500v2.inc b/conf/machine/e500v2.inc
new file mode 100644
index 0000000..165f4c5
--- /dev/null
+++ b/conf/machine/e500v2.inc
@@ -0,0 +1,19 @@
1TARGET_FPU = "ppc-efd"
2
3require conf/machine/include/tune-ppce500v2.inc
4
5MACHINE_FEATURES = "kernel26 pci ext2 ext3 serial"
6MACHINE_EXTRA_RRECOMMENDS = ""
7
8PREFERRED_PROVIDER_virtual/kernel = "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel = "3.0.1"
10PREFERRED_PROVIDER_linux-libc-headers = "linux-qoriq-sdk-headers"
11
12KERNEL_IMAGETYPE = "uImage"
13SERIAL_CONSOLE = "115200 ttyS0"
14IMAGE_FSTYPES = "tar.gz ext2.gz"
15# disable the images below for now
16# ext2.bz2 ext2.lzma \
17# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
18
19MACHINEOVERRIDES .= ":e500v2"
diff --git a/conf/machine/e5500-64b.inc b/conf/machine/e5500-64b.inc
new file mode 100644
index 0000000..7dca179
--- /dev/null
+++ b/conf/machine/e5500-64b.inc
@@ -0,0 +1,20 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce5500-64b.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_FEATURES_RRECOMMENDS = ""
7
8
9PREFERRED_PROVIDER_virtual/kernel = "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel = "3.0.1"
11PREFERRED_PROVIDER_linux-libc-headers = "linux-qoriq-sdk-headers"
12
13KERNEL_IMAGETYPE = "uImage"
14SERIAL_CONSOLE = "115200 ttyS0"
15IMAGE_FSTYPES = "tar.gz ext2.gz"
16# disable the images below for now
17# ext2.bz2 ext2.lzma \
18# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
19
20MACHINEOVERRIDES .= ":e5500-64b"
diff --git a/conf/machine/e5500.inc b/conf/machine/e5500.inc
new file mode 100644
index 0000000..a833a9a
--- /dev/null
+++ b/conf/machine/e5500.inc
@@ -0,0 +1,20 @@
1TARGET_FPU = "hard"
2
3require conf/machine/include/tune-ppce5500-32b.inc
4
5MACHINE_FEATURES = "kernel26 keyboard pci ext2 ext3 serial"
6MACHINE_FEATURES_RRECOMMENDS = ""
7
8
9#PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel ?= "3.0.1"
11PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers"
12
13KERNEL_IMAGETYPE = "uImage"
14SERIAL_CONSOLE = "115200 ttyS0"
15IMAGE_FSTYPES = "tar.gz ext2.gz"
16# disable the images below for now
17# ext2.bz2 ext2.lzma \
18# ext2.gz.u-boot ext2.bz2.u-boot ext2.lzma.u-boot"
19
20MACHINEOVERRIDES .= ":e5500"
diff --git a/conf/machine/mpc8572ds.conf b/conf/machine/mpc8572ds.conf
new file mode 100644
index 0000000..e05d945
--- /dev/null
+++ b/conf/machine/mpc8572ds.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/mpc8572ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
diff --git a/conf/machine/p1020rdb.conf b/conf/machine/p1020rdb.conf
new file mode 100644
index 0000000..f44bdbd
--- /dev/null
+++ b/conf/machine/p1020rdb.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p1020rdb.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
diff --git a/conf/machine/p1022ds.conf b/conf/machine/p1022ds.conf
new file mode 100644
index 0000000..b7d9019
--- /dev/null
+++ b/conf/machine/p1022ds.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p1022ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
diff --git a/conf/machine/p2020ds.conf b/conf/machine/p2020ds.conf
new file mode 100644
index 0000000..1686854
--- /dev/null
+++ b/conf/machine/p2020ds.conf
@@ -0,0 +1,10 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500v2.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p2020ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/mpc85xx_smp_defconfig"
8
9UBOOT_MACHINES = "P2020DS_SDCARD_config P2020DS_config"
10BOOTFORMAT_CONFIG = "config_sram_p2020ds.dat"
diff --git a/conf/machine/p3041ds.conf b/conf/machine/p3041ds.conf
new file mode 100644
index 0000000..90b37fe
--- /dev/null
+++ b/conf/machine/p3041ds.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500mc.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p3041ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
diff --git a/conf/machine/p4080ds.conf b/conf/machine/p4080ds.conf
new file mode 100644
index 0000000..1166f66
--- /dev/null
+++ b/conf/machine/p4080ds.conf
@@ -0,0 +1,9 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e500mc.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p4080ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
8
9UBOOT_MACHINES = "P4080DS_config"
diff --git a/conf/machine/p5020ds-64b.conf b/conf/machine/p5020ds-64b.conf
new file mode 100644
index 0000000..2810caf
--- /dev/null
+++ b/conf/machine/p5020ds-64b.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500-64b.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p5020ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/corenet64_smp_defconfig"
diff --git a/conf/machine/p5020ds.conf b/conf/machine/p5020ds.conf
new file mode 100644
index 0000000..33ef5bb
--- /dev/null
+++ b/conf/machine/p5020ds.conf
@@ -0,0 +1,7 @@
1#@TYPE: Machine
2#@DESCRIPTION: Machine configuration for running
3
4require e5500.inc
5
6KERNEL_DEVICETREE = "${S}/arch/powerpc/boot/dts/p5020ds.dts"
7KERNEL_DEFCONFIG = "${S}/arch/powerpc/configs/corenet32_smp_defconfig"
diff --git a/images/fsl-image-lsb-sdk.bb b/images/fsl-image-lsb-sdk.bb
new file mode 100644
index 0000000..5e0e7ae
--- /dev/null
+++ b/images/fsl-image-lsb-sdk.bb
@@ -0,0 +1,11 @@
1IMAGE_FEATURES += "apps-console-core tools-sdk dev-pkgs ssh-server-openssh"
2EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
3
4
5IMAGE_INSTALL = "\
6 ${POKY_BASE_INSTALL} \
7 task-core-basic \
8 task-core-lsb \
9 "
10
11inherit core-image
diff --git a/images/fsl-image-lsb.bb b/images/fsl-image-lsb.bb
new file mode 100644
index 0000000..22eb7f4
--- /dev/null
+++ b/images/fsl-image-lsb.bb
@@ -0,0 +1,9 @@
1IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
2
3IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \
5 task-core-basic \
6 task-core-lsb \
7 "
8
9inherit core-image
diff --git a/images/fsl-image-minimal.bb b/images/fsl-image-minimal.bb
new file mode 100644
index 0000000..743e121
--- /dev/null
+++ b/images/fsl-image-minimal.bb
@@ -0,0 +1,15 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
5
6IMAGE_LINGUAS = " "
7
8LICENSE = "MIT"
9
10inherit core-image
11
12IMAGE_ROOTFS_SIZE = "8192"
13
14# remove not needed ipkg informations
15ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "