summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2012-06-06 09:47:50 +0000
committerKhem Raj <raj.khem@gmail.com>2012-07-10 20:10:43 -0700
commitc690a247b02e5d0f221034359970b0414da646d8 (patch)
treec1eb183bd9e4e6d954fab4d0e22de0f06c4d405e
parent82dacc0689e443b4d3f1dec80ce22102916aa21a (diff)
downloadmeta-fsl-ppc-c690a247b02e5d0f221034359970b0414da646d8.tar.gz
hv-cfg: package images to hv-cfg-image
images are required to be included in full rootfs. Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--recipes-tools/hv-cfg/hv-cfg_git.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-tools/hv-cfg/hv-cfg_git.bb b/recipes-tools/hv-cfg/hv-cfg_git.bb
index 22c08a2..60847f5 100644
--- a/recipes-tools/hv-cfg/hv-cfg_git.bb
+++ b/recipes-tools/hv-cfg/hv-cfg_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Hypervisor Config" 1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg" 2SECTION = "hv-cfg"
3LICENSE = "BSD" 3LICENSE = "BSD"
4PR = "r4" 4PR = "r5"
5 5
6LIC_FILES_CHKSUM = " \ 6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ 7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
@@ -23,13 +23,22 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git"
23 23
24S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
25 25
26do_deploy () { 26do_install () {
27 make install 27 make install
28 28
29 M=`echo ${MACHINE} | sed s/-64b//g` 29 M=`echo ${MACHINE} | sed s/-64b//g`
30 install -d ${D}/boot/hv-cfg
31 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
32}
33
34do_deploy () {
35 M=`echo ${MACHINE} | sed s/-64b//g`
30 install -d ${DEPLOYDIR}/hv-cfg 36 install -d ${DEPLOYDIR}/hv-cfg
31 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg 37 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
32} 38}
33addtask deploy after do_install 39addtask deploy after do_install
34 40
41PACKAGES += "${PN}-image"
42FILES_${PN}-image += "/boot"
43
35ALLOW_EMPTY_${PN} = "1" 44ALLOW_EMPTY_${PN} = "1"