summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2012-04-20 10:11:21 +0000
committerZhenhua Luo <b19537@freescale.com>2012-04-23 09:56:05 +0800
commitbcb3519cda27a60d9e74eb62bcc6c62ccc911aef (patch)
treef2043b656050b8a702c57e855e8868e1f48e22dd
parent077ee6adccae12920855d8f2e8b28990c99cb49e (diff)
downloadmeta-fsl-ppc-bcb3519cda27a60d9e74eb62bcc6c62ccc911aef.tar.gz
u-boot-sd: skip using boot-format to regenerate images
u-boot images can be deployed to SD using boot-format on target board. This method can leave the SD partition not destoryed. For bug ENGR179814. Signed-off-by: Ting Liu <b28495@freescale.com>
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index 5060741..1b256da 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -5,7 +5,7 @@ PROVIDES = "virtual/bootloader"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
7 7
8PR = "r14" 8PR = "r15"
9INHIBIT_DEFAULT_DEPS = "1" 9INHIBIT_DEFAULT_DEPS = "1"
10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc" 10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc"
11 11
@@ -55,6 +55,7 @@ do_compile () {
55 [ "${MACHINE_ARCH}" == "p3060qds" ] || \ 55 [ "${MACHINE_ARCH}" == "p3060qds" ] || \
56 [ "${MACHINE_ARCH}" == "p4080ds" ] || \ 56 [ "${MACHINE_ARCH}" == "p4080ds" ] || \
57 [ "${MACHINE_ARCH}" == "p5020ds" ] || \ 57 [ "${MACHINE_ARCH}" == "p5020ds" ] || \
58 [ "${UBOOT_TARGET}" == "u-boot-sd" ] || \
58 [ "${UBOOT_TARGET}" == "u-boot-nand" ]; then 59 [ "${UBOOT_TARGET}" == "u-boot-nand" ]; then
59 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin 60 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin
60 else 61 else