summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-04-10 10:54:11 +0800
committerZhenhua Luo <b19537@freescale.com>2012-04-10 10:54:11 +0800
commit9c91f56e76d606d19fadec6290e077a91b253ba2 (patch)
tree96764d13b4c06e57cc2027b711e23fc8736cfc73
parent10abe5bc228553a2b6b4085e56001d508f0e8fb5 (diff)
downloadmeta-fsl-ppc-9c91f56e76d606d19fadec6290e077a91b253ba2.tar.gz
fix u-boot-nand build error of non-dpaa targets
u-boot-nand doesn't need to be handled by boot-format Signed-off-by: Zhenhua Luo <b19537@freescale.com>
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index decb6ec..5060741 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -5,7 +5,7 @@ PROVIDES = "virtual/bootloader"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" 6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
7 7
8PR = "r13" 8PR = "r14"
9INHIBIT_DEFAULT_DEPS = "1" 9INHIBIT_DEFAULT_DEPS = "1"
10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc" 10DEPENDS = "boot-format-native virtual/${TARGET_PREFIX}gcc"
11 11
@@ -54,7 +54,8 @@ do_compile () {
54 [ "${MACHINE_ARCH}" == "p3041ds" ] || \ 54 [ "${MACHINE_ARCH}" == "p3041ds" ] || \
55 [ "${MACHINE_ARCH}" == "p3060qds" ] || \ 55 [ "${MACHINE_ARCH}" == "p3060qds" ] || \
56 [ "${MACHINE_ARCH}" == "p4080ds" ] || \ 56 [ "${MACHINE_ARCH}" == "p4080ds" ] || \
57 [ "${MACHINE_ARCH}" == "p5020ds" ]; then 57 [ "${MACHINE_ARCH}" == "p5020ds" ] || \
58 [ "${UBOOT_TARGET}" == "u-boot-nand" ]; then
58 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin 59 cp ${S}/${board}/u-boot.bin ${S}/${board}/${UBOOT_TARGET}.bin
59 else 60 else
60 ${STAGING_BINDIR_NATIVE}/boot_format \ 61 ${STAGING_BINDIR_NATIVE}/boot_format \